Bug 1769880 - Unable to migrate from OVS to OVN mechanism driver
Summary: Unable to migrate from OVS to OVN mechanism driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 16.0 (Train on RHEL 8.1)
Assignee: Jakub Libosvar
QA Contact: Roman Safronov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 16:31 UTC by Martin Lopes
Modified: 2020-03-03 09:42 UTC (History)
14 users (show)

Fixed In Version: python-networking-ovn-7.1.0-0.20200107221513.eff86ce.el8ost
Doc Type: Known Issue
Doc Text:
There is a known issue where migrations from ML2/OVS to OVN fail. The failure is caused by the new protective mechanism in Red Hat OpenStack Platform director to prevent upgrades while changing mechanism drivers. For the workaround, see "Preparing for the migration" in the Networking with Open Virtual Network guide: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.0/html/networking_with_open_virtual_network/migrating-ml2ovs-to-ovn#preparing_for_the_migration
Clone Of:
Environment:
Last Closed: 2020-03-03 09:41:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 698537 0 None MERGED migration: Use ForceNeutronDriverUpdate when migrating 2020-12-28 18:14:12 UTC
Red Hat Product Errata RHBA-2020:0654 0 None None None 2020-03-03 09:42:08 UTC

Description Martin Lopes 2019-11-07 16:31:57 UTC
Following these steps: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15/html-single/networking_with_open_virtual_network/index#migrating-ml2ovs-to-ovn

We were unable to switch from OVS to the OVN mechanism driver due to the issue described below:

https://opendev.org/openstack/tripleo-common/src/branch/master/tripleo_common/update.py

---
    if current_driver and new_driver and current_driver != new_driver:
        msg = ("Unable to switch from {} to {} neutron "
               "mechanism drivers on upgrade. Please consult the "
               "documentation.").format(current_driver, new_driver)
        return msg
----

As a result, removed `return msg` and was able to progress past this point.

For more information, see https://opendev.org/openstack/tripleo-common/commit/379f886119727fe440e384234db53f48730e27ad

Comment 1 Jakub Libosvar 2019-11-19 13:51:29 UTC
Martin, can you describe which step/command is failing for you? Is it "ovn_migration.sh start-migration" ?

Comment 2 Martin Lopes 2019-11-19 16:40:37 UTC
Hi Harald, for comment 1: would you remember if this occurred under `ovn_migration.sh start-migration`?

Comment 3 Harald Jensås 2019-11-26 08:09:28 UTC
(In reply to Martin Lopes from comment #2)
> Hi Harald, for comment 1: would you remember if this occurred under
> `ovn_migration.sh start-migration`?

Yes, this happend at the `ovn_migration.sh start-migration` step. That step does: "Updates the overcloud stack to deploy OVN alongside reference implementation services using the temporary bridge br-migration instead of br-int.", which fails due to the check added in https://opendev.org/openstack/tripleo-common/commit/379f886119727fe440e384234db53f48730e27ad. I think that check could look for 'br-migration' in case 'current_driver and new_driver and current_driver != new_driver' and let the update continue if 'br-migration' is there.


--
Harald

Comment 14 Roman Safronov 2020-02-19 09:10:49 UTC
Verified on 16.0-RHEL-8/RHOS_TRUNK-16.0-RHEL-8-20200213.n.1 with python3-networking-ovn-7.1.0-0.20200204065607.57ac389.el8ost.noarch

Verified that migration process is not blocked on this stage and proceeds till the end (in case workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1804376 is applied)

Comment 16 errata-xmlrpc 2020-03-03 09:41:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0654


Note You need to log in before you can comment on or make changes to this bug.