Bug 1769927 - Image Registry Operator Allows Edits to Registry Deployment
Summary: Image Registry Operator Allows Edits to Registry Deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 17:51 UTC by Adam Kaplan
Modified: 2020-05-13 21:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:52:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 448 0 None closed WIP - Bug 1769927: Persistent Deployment 2020-09-10 04:23:27 UTC
Github openshift cluster-image-registry-operator pull 451 0 None closed Bug 1769927: Persistent Deployment 2020-09-10 04:23:29 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:52:29 UTC

Description Adam Kaplan 2019-11-07 17:51:50 UTC
Description of problem:
A cluster admin can make arbitrary changes to the image registry's deployment, and the image registry operator will leave these changes in place as long as other configuration has not changed.

Version-Release number of selected component (if applicable): 4.1.z


How reproducible: Always


Steps to Reproduce:
1. `oc edit deployment image-registry -n openshift-image-registry`
2. Add an environment variable to the pod template spec - ex: name: FOO, value: BAR
3. Wait for the registry deployment to roll out

Actual results:
Added environment variable is present in the image registry pod.


Expected results:
Image registry operator undoes the edit to the pod template spec, and when rollouts complete the registry pods do not contain the added environment variable.


Additional info:

Comment 1 Ben Parees 2019-11-07 21:49:07 UTC
at a minimum these changes should be getting stomped on our next sync/reconcile loop (not sure what the interval is on that these days).  if they are not, that's definitely a bug.

Comment 3 Oleg Bulatov 2020-02-03 10:55:35 UTC
The pull request is merged.

Comment 5 Wenjing Zheng 2020-02-07 09:40:08 UTC
Verified on 4.4.0-0.nightly-2020-02-06-230833, the changes made in image-registry deployment will be reverted.

Comment 7 errata-xmlrpc 2020-05-13 21:52:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.