Bug 176995 - daap discovery doesn't seem to work
daap discovery doesn't seem to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 22:49 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 13:15:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 309609 None None None Never

  None (edit)
Description Thomas J. Baker 2006-01-04 22:49:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
daap discovery doesn't seem to work. I don't see any other systems sharing music. I have Rhythmbox installed on my Nokia 770 and it does see the servers on my network.

Version-Release number of selected component (if applicable):
rhythmbox-0.9.2-4

How reproducible:
Always

Steps to Reproduce:
1.start rhythmbox
2.wait for daap discovery
3.
  

Actual Results:  nothing

Expected Results:  daap servers should have appeared

Additional info:
Comment 1 Alex Lancaster 2006-01-10 03:27:35 EST
This easily fixed, need to add --enable-daap to the %configure in the spec file,
current version 1.37 doesn't include it:

http://cvs.fedora.redhat.com/viewcvs/rpms/rhythmbox/devel/rhythmbox.spec?rev=1.37&view=auto

Is it possible to do a rebuild?
Comment 2 Alex Lancaster 2006-01-20 20:40:53 EST
Ping, any chance of a rebuild with DAAP enabled?  I noticed that rhythmbox was
recently rebuilt with iPod support.
Comment 3 Alex Lancaster 2006-01-20 20:58:44 EST
Hmm, I just realised that rhythmbox in Rawhide may be being built with gstreamer
0.10, if so, DAAP doesn't work with rhythmbox 0.9.2 and gstreamer 0.10, but it
is the process of being ported. See:

http://bugzilla.gnome.org/show_bug.cgi?id=309609

However there is a good chance that it will be fixed by 0.9.3.
Comment 4 Alex Lancaster 2006-01-24 09:08:35 EST
DAAP discovery is about to go gold in rhythmbox CVS:

http://mail.gnome.org/archives/rhythmbox-devel/2006-January/msg00085.html

and since you seem to be building CVS snapshots of rhythmbox for rawhide in any
case, any chance you could add --enable-daap to the spec file and rebuild for
rawhide so we could do some testing before the next test release?

Would be a nice feature for FC5... ;-)
Comment 5 Alex Lancaster 2006-01-24 09:11:49 EST
Btw,  DAAP works with gstreamer 0.10 now, with this change (which is now in the
rawhide package):

2006-01-21  Jonathan Matthew  <jonathan@kaolin.hn.org>

        * configure.ac: Don't disable DAAP with gstreamer 0.10

        * daapsharing/rb-daap-src.c: (_do_init), (rb_daap_src_base_init),
        (rb_daap_src_class_init), (rb_daap_src_init),
        (rb_daap_src_finalize), (rb_daap_src_set_property),
        (rb_daap_src_get_property), (rb_daap_src_write),
        (rb_daap_src_read), (_expect_char), (rb_daap_src_read_chunk_size),
        (_split_uri), (rb_daap_src_open):
        * daapsharing/rb-daap-src.h:
        Mostly fix seeking, handle chunked transfer encoding, and port to
        gstreamer 0.10.

        * player/rb-player-gst.c:
        * sources/rb-daap-source.c: (start_browsing), (stop_browsing):
        Remove rb_daap_src_initialize and rb_daap_src_shutdown.

        Fixes bugs #326738 and #318852, and brings #309609 one step closer to
        being fixed.

Comment 6 John (J5) Palmieri 2006-01-24 09:49:41 EST
Reassigning to caillon who is working on rhythmbox packaging right now.
Comment 7 Alex Lancaster 2006-02-02 12:04:00 EST
Appears to be fixed in latest Rawhide with rhythmbox-0.9.3-2.  I can now browse
remote shares.

In the 0.9.3 version of rhythmbox DAAP is enabled by default if the correct
dependencies are found.

Note You need to log in before you can comment on or make changes to this bug.