Bug 1769992 - etcd: server certs should support client usage
Summary: etcd: server certs should support client usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1805569 (view as bug list)
Depends On: 1769985
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 20:58 UTC by Sam Batschelet
Modified: 2020-05-13 11:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1769985
Environment:
Last Closed: 2020-05-13 11:07:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift kubecsr pull 17 None closed Bug 1769992: pkg/certsigner/signer: Add "client" usage to server profile 2020-07-21 20:37:30 UTC
Red Hat Product Errata RHBA-2020:2023 None None None 2020-05-13 11:07:37 UTC

Description Sam Batschelet 2019-11-07 20:58:25 UTC
+++ This bug was initially created as a clone of Bug #1769985 +++

Description of problem: openshift/kubecsr repo is the canonical home for etcd cert signer. PR #22 added client usage and was merged upstream and is part of master downstream.[1] 

[1]: https://github.com/openshift/kubecsr/commit/aad75d333646da657e788db93f2ff75da850b542#diff-654ba8df3be94fe94c9404a7727d1fa2

But this was never backported to the openshift-4.1, openshift-4.2 or openshift-4.3. With etcd 3.3.10 the result is an error message during startup 

> 2019-11-07 14:18:08.592903 I | embed: rejected connection from "127.0.0.1:32972" (error "tls: failed to verify client's certificate: x509: certificate specifies an incompatible key usage", ServerName "")


In 3.3.17 we see many more of these errors and the result will be unnecessary bugs and spammy logs. 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: Backport is complete


Additional info:

Comment 1 Sam Batschelet 2020-04-08 13:39:38 UTC
*** Bug 1805569 has been marked as a duplicate of this bug. ***

Comment 3 W. Trevor King 2020-04-08 20:38:34 UTC
Linking the 4.2 backport, while we wait for the Bugzilla bot to get fixed.

Comment 11 errata-xmlrpc 2020-05-13 11:07:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2023


Note You need to log in before you can comment on or make changes to this bug.