Bug 1770108 - Miss description info for CRD servicecatalogcontrollermanagers
Summary: Miss description info for CRD servicecatalogcontrollermanagers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Jesus M. Rodriguez
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-08 06:51 UTC by Fan Jia
Modified: 2020-01-23 11:12 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:11:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-svcat-controller-manager-operator pull 62 0 'None' 'open' 'Bug 1770108: remove the old config.crd, fix explain' 2019-11-16 02:21:14 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:12:09 UTC

Description Fan Jia 2019-11-08 06:51:26 UTC
Description of problem:
Should add the description info for CRD servicecatalogcontrollermanagers.
#oc explain servicecatalogcontrollermanagers|grep -i description -A 3
DESCRIPTION:
     <empty>


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-07-172437

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.3.
2. Login this cluster as a cluster-admin.
3. Check the CRD servicecatalogcontrollermanagers
$ oc explain servicecatalogcontrollermanagers|grep -i description -A 3

Actual results:
Get nothing about the descrioption.
#oc explain servicecatalogcontrollermanagers|grep -i description -A 3
DESCRIPTION:
     <empty>

Expected results:
Should get the appropriate description for CRD servicecatalogcontrollermanagers

Additional info:

Comment 2 Fan Jia 2019-11-19 07:42:15 UTC
test env:
cv:4.3.0-0.nightly-2019-11-19-053808

test result:
$ oc explain servicecatalogcontrollermanagers
KIND:     ServiceCatalogControllerManager
VERSION:  operator.openshift.io/v1

DESCRIPTION:
     ServiceCatalogControllerManager provides information to configure an
     operator to manage Service Catalog Controller Manager

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object> -required-

   status	<Object>

Comment 4 errata-xmlrpc 2020-01-23 11:11:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.