Bug 1770122 - Microphone and sound issues with Intel HDA and codec ALC285 (Lenovo X1 Carbon 7th gen)
Summary: Microphone and sound issues with Intel HDA and codec ALC285 (Lenovo X1 Carbon...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 31
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-08 08:44 UTC by Stefano Passiglia
Modified: 2020-09-21 07:15 UTC (History)
33 users (show)

Fixed In Version: pulseaudio-13.99.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 07:15:59 UTC
Type: Bug


Attachments (Terms of Use)
Output of journalctl --no-hostname -k > dmesg.txt (91.28 KB, text/plain)
2019-11-08 08:44 UTC, Stefano Passiglia
no flags Details
Output of alsa-info (41.41 KB, text/plain)
2019-11-08 08:45 UTC, Stefano Passiglia
no flags Details
gnome sound control panel showing that microphone is not recognized (69.74 KB, image/png)
2019-11-08 08:46 UTC, Stefano Passiglia
no flags Details
Gnome sound control panel after plugging headset - now microphone is recognized (72.20 KB, image/png)
2019-11-08 08:47 UTC, Stefano Passiglia
no flags Details
Alsa-mixer screenshot (36.71 KB, image/png)
2019-11-08 08:48 UTC, Stefano Passiglia
no flags Details
Sound configuration after patch (65.49 KB, image/png)
2020-03-20 13:48 UTC, Stefano Passiglia
no flags Details

Description Stefano Passiglia 2019-11-08 08:44:31 UTC
Created attachment 1633923 [details]
Output of journalctl --no-hostname -k > dmesg.txt

Brand new Lenovo X1 Carbon. Clean F31 install.
System sound volume control doesn't adjust volume, neither with the Fn key nor with the Gnome sound slider. Seems that is overruled by the application volume setting.
Laptop microphone doesn't work. If I plug an headset then it works. Also, in this case, headphone volume can be adjusted with both the Fn keys or Gnome volume control slider

2. What is the Version-Release number of the kernel:
$ uname -a
Linux new-host-6 5.3.8-300.fc31.x86_64 #1 SMP Tue Oct 29 14:28:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

3. Did it work previously in Fedora? 
Can't say as this is a new laptop with a different sound card

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
System sound volume control doesn't adjust volume, neither with the Fn key nor with the Gnome sound slider. Seems that is overruled by the application volume setting.
Laptop microphone doesn't work. If I plug an headset then it works. Also, in this case, headphone volume can be adjusted with both the Fn keys or Gnome volume control slider

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
I can't use rawhide as this is my work laptop

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Stefano Passiglia 2019-11-08 08:45:14 UTC
Created attachment 1633924 [details]
Output of alsa-info

Comment 2 Stefano Passiglia 2019-11-08 08:46:21 UTC
Created attachment 1633925 [details]
gnome sound control panel showing that microphone is not recognized

Comment 3 Stefano Passiglia 2019-11-08 08:47:15 UTC
Created attachment 1633926 [details]
Gnome sound control panel after plugging headset - now microphone is recognized

Comment 4 Stefano Passiglia 2019-11-08 08:48:11 UTC
Created attachment 1633927 [details]
Alsa-mixer screenshot

Comment 5 Stefano Passiglia 2019-11-21 13:55:30 UTC
Seems linked to this bug here:

https://bugzilla.kernel.org/show_bug.cgi?id=201251

Comment 6 Fedora Update System 2020-03-09 20:34:50 UTC
pulseaudio-13.99.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c3e19f5098

Comment 7 Fedora Update System 2020-03-19 01:43:57 UTC
pulseaudio-13.99.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Jiří Vozár 2020-03-20 12:25:37 UTC
The patch solves just part of the problem. It is necessary to install package alsa-firmware and remove package alsa-ucm to make the sound work correctly:

$ sudo dnf install alsa-firmware
$ sudo dnf erase alsa-ucm

The fix doesn't work without mentioned package installation and deletion.

This step is discussed in Bug 1782148.

Comment 9 Stefano Passiglia 2020-03-20 13:46:53 UTC
In addition I needed the following

$ echo "options snd-intel-dspcfg dsp_driver=0" > /etc/modprobe.d/alsa.conf

0 is for auto mode.

With this configuration I get the microphone finally recognized (attached screenshot) as "Multichannel Input - Cannon Point-LP High Definition Audio Controller"

but can't record any sound - tested with gnome-sound-recorder.

I also forced SOF mode (dsp_driver=3) but still can't record sound.

Speakers work correctly.

Comment 10 Stefano Passiglia 2020-03-20 13:48:03 UTC
Created attachment 1671902 [details]
Sound configuration after patch

Comment 11 Stefano Passiglia 2020-03-20 14:01:28 UTC
Output of dmesg| grep sof

[    5.369199] sof-audio-pci 0000:00:1f.3: warning: No matching ASoC machine driver found
[    5.369204] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[    5.369361] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.373563] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[    5.379062] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[    5.379063] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    5.425522] sof-audio-pci 0000:00:1f.3: unexpected ipc interrupt raised!
[    5.425524] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
[    5.515623] sof-audio-pci 0000:00:1f.3: Firmware info: version 1:1:0-fcf6c
[    5.515624] sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:11:0 Kernel ABI 3:11:0
[    5.516334] sof-audio-pci 0000:00:1f.3: firmware boot complete
[    5.522721] sof-audio-pci 0000:00:1f.3: Topology: ABI 3:11:0 Kernel ABI 3:11:0
[    5.522725] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp3 Tx not handled
[    5.524234] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec0_in not handled
[    5.524235] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp2 Tx not handled
[    5.526824] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec1_in not handled
[    5.526826] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp1 Tx not handled
[    5.529007] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec0_out not handled
[    5.529012] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Analog CPU Playback not handled
[    5.529818] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec1_out not handled
[    5.529820] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Digital CPU Playback not handled
[    5.529822] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec2_in not handled
[    5.529824] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Alt Analog CPU Playback not handled
[    5.529825] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec2_out not handled
[    5.529826] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Analog CPU Capture not handled
[    5.530542] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp1_out not handled
[    5.530543] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Digital CPU Capture not handled
[    5.531314] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp2_out not handled
[    5.531315] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Alt Analog CPU Capture not handled
[    5.532105] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp3_out not handled
[    5.543669] sof-audio-pci 0000:00:1f.3: ASoC: Parent card not yet available, widget card binding deferred
[    5.627769] input: sof-hda-dsp Headset Jack as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input16
[    5.627836] input: sof-hda-dsp Mic as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input17
[    5.627876] input: sof-hda-dsp Headphone as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input18
[    5.627917] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input19
[    5.627955] input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input20
[    5.627993] input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0/input21
[    9.062434] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
[    9.150286] sof-audio-pci 0000:00:1f.3: firmware boot complete
[   52.624719] sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
[   52.719842] sof-audio-pci 0000:00:1f.3: firmware boot complete

Comment 12 glise 2020-09-19 14:43:57 UTC
hello everyone,
i'm experiencing the same issue as you.

it might be helpful to share my alsa-info

do you have any suggestion to fix it ?

thanks 
glise

Comment 14 Hans de Goede 2020-09-21 07:13:29 UTC
(In reply to Jiří Vozár from comment #8)
> The patch solves just part of the problem. It is necessary to install
> package alsa-firmware and remove package alsa-ucm to make the sound work
> correctly:
> 
> $ sudo dnf install alsa-firmware

Correct, the kernel package has been modified to Suggest this now, which will make dnf automatically install it.

> $ sudo dnf erase alsa-ucm

Erm, no please don't you need alsa-ucm for new laptops which use the SOF driver to work correctly, please re-install alsa-ucm.

(In reply to Stefano Passiglia from comment #9)
> In addition I needed the following
> 
> $ echo "options snd-intel-dspcfg dsp_driver=0" > /etc/modprobe.d/alsa.conf
> 
> 0 is for auto mode.

0 is the default, so unless you have made some modifications somewhere else this should not be necessary.

Many Fedora users have a X1C7 and both the problems with only 2 of the 4 speakers working and the microphones not working have been resolved for a while now, so I'm closing this.

If you are still having issues, please make sure that you undo any modifications to your system. So:

1. No special kernel commandline arguments

2. No modprobe.conf changes, run:
rpm -qf /etc/modprobe.d/*.conf
And check files which are not owned by a package. You may also want to run "rpm --verify <package>" on listed packages

3. No alsa config changes, run: rpm -qf /etc/alsa/*.conf /etc/alsa/conf.d/*.conf
And check files which are not owned by a package. Also run "rpm --verify <package>" on listed packages

Since this is working for almost all X1C7 users now, if it still does not work this is almost certainly something specific to your system, so I'm closing this bug now.

Comment 15 Hans de Goede 2020-09-21 07:15:43 UTC
(In reply to glise from comment #13)
> http://alsa-project.org/db/?f=5dcd4f09c57dc9f657fa9b84e8b64c882a782e92
> 
> the link

Your alsa-info shows that you are not using a X1 carbon 7th gen, which is what this bug is about, please file a new bug against the alsa-lib (*) component for your issue.

*) picking the alsa-lib component ensures that this is brought to the attention of the kernel sound (alsa) subsystem maintainers


Note You need to log in before you can comment on or make changes to this bug.