Bug 177021 - mouse pointer disappears after screen saver started
Summary: mouse pointer disappears after screen saver started
Status: CLOSED DUPLICATE of bug 106552
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-05 13:33 UTC by Felix Schwarz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 13:37:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felix Schwarz 2006-01-05 13:33:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
In VNC full screen mode, the mouse pointer is gone after the screen saver started. It will only reappear after the X-Server terminates.

Version-Release number of selected component (if applicable):
vnc-4.1.1-10.1

How reproducible:
Always

Steps to Reproduce:
1. Use the screen saver "Blank Screen Only", set blanking time to 1 minute (not required, but easier to reproduce this way)
2. use vncclient to connect to a remote vnc server
3. switch to full screen mode (F8)
4. wait untill the screen saver started
5. move the mouse to disable the screen saver


Actual Results:  No mouse pointer is visible any more. Right click still works but no left clicks. It is not possible to leave the VNC full screen mode.

Expected Results:  Mouse pointer should work normally. Left clicks should work. 

Additional info:

The mouse pointer reappears if I kill the X-Server (Ctrl+Alt+Backspace) and log in again. Unplugging and replugging the mouse (USB) does not help. When I switch to the console (Ctrl+Alt+F1), GPM still lets me use the mouse.

Comment 1 Tim Waugh 2006-01-05 13:37:36 UTC

*** This bug has been marked as a duplicate of 106552 ***


Note You need to log in before you can comment on or make changes to this bug.