Bug 1770269 - [DR]etcd client should be inline with what is shipped with product.
Summary: [DR]etcd client should be inline with what is shipped with product.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-08 15:07 UTC by Sam Batschelet
Modified: 2020-01-23 11:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:11:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1272 0 'None' 'closed' 'Bug 1770269: DR: etcdctl version should match with what is shipped with product' 2019-11-28 11:12:09 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:12:03 UTC

Description Sam Batschelet 2019-11-08 15:07:15 UTC
Description of problem: etcdctl is downloading the wrong version of the client. We should make the etcd version a default in https://github.com/openshift/machine-config-operator/blob/master-4.3/templates/master/00-master/_base/files/usr-local-bin-openshift-recovery-tools-sh.yaml. So that it only needs to be set once.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: etcdctl used in 4.3 is v3.3.17


Additional info:

Comment 2 ge liu 2019-11-29 07:54:29 UTC
Verified with 4.3.0-0.nightly-2019-11-29-040907

Comment 4 errata-xmlrpc 2020-01-23 11:11:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.