Bug 177030 - ia64 floating-point assist fault from ntpd
ia64 floating-point assist fault from ntpd
Status: CLOSED DUPLICATE of bug 147980
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ntp (Show other bugs)
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-01-05 10:42 EST by Doug Chapman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-04 07:20:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ntp.conf file (I believe this is unmodified from the rpm but just in case...) (2.38 KB, text/plain)
2006-01-05 10:53 EST, Doug Chapman
no flags Details
ntp-4.2.0.a.20050816-2.src.rpm (3.92 MB, application/x-rpm)
2006-01-06 08:35 EST, Petr Raszyk
no flags Details

  None (edit)
Description Doug Chapman 2006-01-05 10:42:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
When running for more than a couple of days I start seeing the following messages on my ia64 systems.  I am seeing this on both RHEL4 U2 and U3 so it is not a (recent) regression.

ntpd(2355): floating-point assist fault at ip 2000000800047962, isr 0000040000000008
ntpd(2355): floating-point assist fault at ip 2000000800047971, isr 0000020000000008
ntpd(2355): floating-point assist fault at ip 20000008001eb701, isr 0000020000000008

these 3 messages all happen at the same time in approx 1 minute intervals (which fills up logs pretty quickly).  The ntpd binary is stripped so I am not able to determine what part of the code is causing this.  I will try to build a debug version and see if I can reproduce with that.

Since it sounds like other people have not seen this it might be something due to my ntpd.conf file.  I will attach that here.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install my ntpd.conf on an ia64 system
2. start ntpd
3. wait a couple of days

Additional info:
Comment 1 Doug Chapman 2006-01-05 10:53:00 EST
Created attachment 122831 [details]
ntp.conf file (I believe this is unmodified from the rpm but just in case...)

Attaching the ntp.conf file.  Nothing special and I don't think I have modified
it from what was supplied in the rpm.
Comment 2 Petr Raszyk 2006-01-06 08:35:02 EST
Created attachment 122871 [details]

Thanks for your ntp.conf file.
ntpd is running on our common x86_64 machine (using your ntp.conf) now.
Can you try it too (in your scenario, using *.src.rpm above) ?
It creates /tmp/ntpd.PID and /tmp/ntpd-last.PID files.
Please, can you send me these files (after 'crash') ?

/tmp/ntpd.PID (ca. first 10000 lines)
/tmp/ntpd-last.PID (ca. last 1000 lines)
Comment 3 Doug Chapman 2006-01-06 10:58:19 EST
I am running using the .src.rpm now.  I will let it run over the weekend since
it seems to take a day or two before the problem shows up.

FYI, I don't think you will see the behavior on x86_64 since I _think_ the
"floating-point assist" message is an ia64 specific thing.

Also, for clarification on your request.  You say to send the files after
"crash".  Are you saying this version of ntp should crash ntp when I get the
errors?  (it was not crashing before, just kept spitting out the messages". 
Also, not sure what you mean by "ca. first 10000 lines".
Comment 5 Miroslav Lichvar 2006-04-04 07:20:44 EDT

*** This bug has been marked as a duplicate of 147980 ***

Note You need to log in before you can comment on or make changes to this bug.