Bug 1770439 - Dependency problem with freecad-1:0.18.3-5.fc31.1.x86_64
Summary: Dependency problem with freecad-1:0.18.3-5.fc31.1.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1771010 1773209 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-09 08:20 UTC by Jan Vlug
Modified: 2019-11-18 22:47 UTC (History)
5 users (show)

Fixed In Version: freecad-0.18.4-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 01:36:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Vlug 2019-11-09 08:20:01 UTC
When I try to dnf update my system, I get:

# dnf update
Last metadata expiration check: 0:16:10 ago on Sat 09 Nov 2019 08:43:15 CET.
Dependencies resolved.

 Problem 1: package freecad-1:0.18.3-5.fc31.1.x86_64 requires libpyside2.cpython-37m-x86_64-linux-gnu.so.5.13()(64bit), but none of the providers can be installed
  - cannot install both python3-pyside2-1:5.12.5-1.fc31.1.x86_64 and python3-pyside2-5.13.1-2.fc31.x86_64
  - cannot install both python3-pyside2-5.13.1-2.fc31.x86_64 and python3-pyside2-1:5.12.5-1.fc31.1.x86_64
  - cannot install the best update candidate for package python3-pyside2-5.13.1-2.fc31.x86_64
  - cannot install the best update candidate for package freecad-1:0.18.3-5.fc31.1.x86_64
 Problem 2: package freecad-data-1:0.18.3-5.fc31.1.noarch requires freecad = 1:0.18.3-5.fc31.1, but none of the providers can be installed
  - package freecad-1:0.18.3-5.fc31.1.x86_64 requires libshiboken2.cpython-37m-x86_64-linux-gnu.so.5.13()(64bit), but none of the providers can be installed
  - cannot install both python3-shiboken2-1:5.12.5-1.fc31.1.x86_64 and python3-shiboken2-5.13.1-2.fc31.x86_64
  - cannot install both python3-shiboken2-5.13.1-2.fc31.x86_64 and python3-shiboken2-1:5.12.5-1.fc31.1.x86_64
  - cannot install the best update candidate for package python3-shiboken2-5.13.1-2.fc31.x86_64
  - cannot install the best update candidate for package freecad-data-1:0.18.3-5.fc31.1.noarch
===============================================================================================================================================================
 Package                                    Architecture                    Version                                     Repository                        Size
===============================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 python3-pyside2                            x86_64                          1:5.12.5-1.fc31.1                           updates                          8.6 M
 python3-shiboken2                          x86_64                          1:5.12.5-1.fc31.1                           updates                          184 k

Transaction Summary
===============================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Comment 1 Richard Shaw 2019-11-10 19:39:56 UTC
There are packages in testing that should fix this, please try them out:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-1ff1241c0f

Comment 2 Jan Vlug 2019-11-10 22:13:57 UTC
I confirm that the dependency issue has been fixed. Thanks!

Comment 3 Richard Shaw 2019-11-11 17:15:01 UTC
*** Bug 1771010 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-11-11 20:41:11 UTC
FEDORA-2019-1ff1241c0f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1ff1241c0f

Comment 5 Richard Shaw 2019-11-16 18:37:35 UTC
*** Bug 1773209 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-11-18 01:36:47 UTC
freecad-0.18.4-1.fc31, opencascade-7.4.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Brent R Brian 2019-11-18 11:27:08 UTC
 freecad                                                            x86_64                                   1:0.18.4-1.fc31                                                          updates                                            31 M
 freecad-data                                                       noarch                                   1:0.18.4-1.fc31                                                          updates                                           169 M

 python3-pyside2                                                    x86_64                                   1:5.12.5-1.fc31.1                                                        updates                                           8.6 M
 python3-shiboken2                                                  x86_64                                   1:5.12.5-1.fc31.1                                                        updates                                           184 k

Looks good!

Thanks!

Happy Holidays to all of you.

Comment 8 Fedora Update System 2019-11-18 22:47:16 UTC
freecad-0.18.4-1.fc31, opencascade-7.4.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.