Bug 177056 - bash-completion quoting issues with bash 3.1
Summary: bash-completion quoting issues with bash 3.1
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bash-completion   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-05 20:35 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 20050721-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 20:57:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Potential sample fix (527 bytes, patch)
2006-01-05 20:35 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2006-01-05 20:35:17 UTC
$ scp 19<TAB>
+++ sed -ne 's/^[Hh][Oo][Ss][Tt][' ']*\([^*?]*\)$/\1/p' /etc/ssh/ssh_config
/home/scop/.ssh/config
sed: -e expression #1, char 20: unterminated `s' command


Attached patch seems to fix this (needs to be applied in other places in
bash_completion as well), patch forwarded upstream and comments requested.

Comment 1 Ville Skyttä 2006-01-05 20:35:18 UTC
Created attachment 122842 [details]
Potential sample fix

Comment 2 John Ellson 2006-01-07 22:20:16 UTC
Same problem here with: ssh localh<ESC><ESC>
Patch works for me.


Comment 3 Ville Skyttä 2006-01-17 20:57:28 UTC
Thanks for testing and the feedback.  I haven't heard from upstream, so
committed a patch which changes other similar constructs as well; been running
with it for a while and noticed no problems.  This will be in the next Extras push.


Note You need to log in before you can comment on or make changes to this bug.