Bug 177058 - oops starting cd install
oops starting cd install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-05 15:47 EST by Jeremy Katz
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 23:43:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-01-05 15:47:57 EST
The installer is oopsing when we go to start a CD install with an fc5 test2
prototree.  2.6.15-1.1819_FC5 is the kernel.  This looks a lot like what we were
seeing right before test1 also -- booting with elevator=as makes things work :-/

Oops: 0000 [#1]
last sysfs file:
/devices/pci0000:00/0000:00:1d.7/usb1/1-0:1.0/bAlternateSettingModules linked
in: usb_storage ata_piix libata e1000 ohci1394 ieee1394 uhci_hcdsCPU:    0
EIP:    0060:[<c01c312e>]    Not tainted VLI
EFLAGS: 00010002   (2.6.15-1.1819_FC5)
EIP is at rb_next+0x9/0x22
eax: 6b6b6b6b   ebx: dfed01f8   ecx: c01bf65a   edx: 6b6b6b6b
esi: c1991e98   edi: 00000202   ebp: dfed403c   esp: c03c1f14
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 0, threadinfo=c03c1000 task=c0327ba0)
Stack: c01bf662 c01b5dfa dfed01f8 c01b85dc c040c284 00000004 c1991e98 c023c8ab
       c1991e98 00000000 c040c284 00000000 c023d3a4 000194d0 00000000 dfed403c
       c1991e98 c040c284 c1991e98 00000000 c0231f2d 000194d0 00000000 000194d0
Call Trace:
 [<c01bf662>] cfq_latter_request+0x8/0x14     [<c01b5dfa>] elv_latter_request+07
[<c01b85dc>] blk_attempt_remerge+0x1d/0x3c     [<c023c8ab>] cdrom_start_read+0e
[<c023d3a4>] ide_do_rw_cdrom+0xdd/0x14a     [<c0231f2d>] start_request+0x1b1/01
[<c023220f>] ide_do_request+0x2a0/0x2fb     [<c023265e>] ide_intr+0xf3/0x11b
 [<c023c1a7>] cdrom_read_intr+0x0/0x2a1     [<c013632a>] handle_IRQ_event+0x23/c
[<c01363cd>] __do_IRQ+0x7a/0xcd     [<c01054d0>] do_IRQ+0x5c/0x77
 =======================
 [<c0103cea>] common_interrupt+0x1a/0x20     [<c0101120>] mwait_idle+0x1a/0x2e
 [<c01010a3>] cpu_idle+0x38/0x4d     [<c0390635>] start_kernel+0x17a/0x17c
Code: 85 c0 74 0b 8b 50 0c 85 d2 74 04 89 d0 eb f5 c3 8b 00 85 c0 74 0b 8b 50 0
Badness in show_registers at arch/i386/kernel/traps.c:277 (Not tainted)
 [<c01042e6>] show_registers+0x192/0x1d0     [<c010445c>] die+0xcb/0x14f
 [<c0114445>] do_page_fault+0x0/0x4cd     [<c01147c4>] do_page_fault+0x37f/0x4cd
[<c01c312e>] rb_next+0x9/0x22     [<c0114445>] do_page_fault+0x0/0x4cd
 [<c0103ddf>] error_code+0x4f/0x60     [<c01bf65a>] cfq_latter_request+0x0/0x14
 [<c01c312e>] rb_next+0x9/0x22     [<c01bf662>] cfq_latter_request+0x8/0x14
 [<c01b5dfa>] elv_latter_request+0x15/0x17     [<c01b85dc>] blk_attempt_remergec
[<c023c8ab>] cdrom_start_read+0x4d/0x9e     [<c023d3a4>] ide_do_rw_cdrom+0xdd/a
[<c0231f2d>] start_request+0x1b1/0x1d1     [<c023220f>] ide_do_request+0x2a0/0b
 [<c023265e>] ide_intr+0xf3/0x11b     [<c023c1a7>] cdrom_read_intr+0x0/0x2a1
 [<c013632a>] handle_IRQ_event+0x23/0x4c     [<c01363cd>] __do_IRQ+0x7a/0xcd
 [<c01054d0>] do_IRQ+0x5c/0x77
 =======================
 [<c0103cea>] common_interrupt+0x1a/0x20     [<c0101120>] mwait_idle+0x1a/0x2e
 [<c01010a3>] cpu_idle+0x38/0x4d     [<c0390635>] start_kernel+0x17a/0x17c
 <0>Kernel panic - not syncing: Fatal exception in interrupt
 [<c0118cfe>] panic+0x3e/0x15e     [<c01044d6>] die+0x145/0x14f
 [<c0114445>] do_page_fault+0x0/0x4cd     [<c01147c4>] do_page_fault+0x37f/0x4cd
[<c01c312e>] rb_next+0x9/0x22     [<c0114445>] do_page_fault+0x0/0x4cd
 [<c0103ddf>] error_code+0x4f/0x60     [<c01bf65a>] cfq_latter_request+0x0/0x14
 [<c01c312e>] rb_next+0x9/0x22     [<c01bf662>] cfq_latter_request+0x8/0x14
 [<c01b5dfa>] elv_latter_request+0x15/0x17     [<c01b85dc>] blk_attempt_remergec
[<c023c8ab>] cdrom_start_read+0x4d/0x9e     [<c023d3a4>] ide_do_rw_cdrom+0xdd/a
[<c0231f2d>] start_request+0x1b1/0x1d1     [<c023220f>] ide_do_request+0x2a0/0b
[<c023265e>] ide_intr+0xf3/0x11b     [<c023c1a7>] cdrom_read_intr+0x0/0x2a1
 [<c013632a>] handle_IRQ_event+0x23/0x4c     [<c01363cd>] __do_IRQ+0x7a/0xcd
 [<c01054d0>] do_IRQ+0x5c/0x77
 =======================
 [<c0103cea>] common_interrupt+0x1a/0x20     [<c0101120>] mwait_idle+0x1a/0x2e
 [<c01010a3>] cpu_idle+0x38/0x4d     [<c0390635>] start_kernel+0x17a/0x17c
 Badness in panic at kernel/panic.c:139 (Not tainted)
 [<c0118e0b>] panic+0x14b/0x15e     [<c01044d6>] die+0x145/0x14f
 [<c0114445>] do_page_fault+0x0/0x4cd     [<c01147c4>] do_page_fault+0x37f/0x4cd
[<c01c312e>] rb_next+0x9/0x22     [<c0114445>] do_page_fault+0x0/0x4cd
 [<c0103ddf>] error_code+0x4f/0x60     [<c01bf65a>] cfq_latter_request+0x0/0x14
 [<c01c312e>] rb_next+0x9/0x22     [<c01bf662>] cfq_latter_request+0x8/0x14
 [<c01b5dfa>] elv_latter_request+0x15/0x17     [<c01b85dc>] blk_attempt_remergec
[<c023c8ab>] cdrom_start_read+0x4d/0x9e     [<c023d3a4>] ide_do_rw_cdrom+0xdd/a
[<c0231f2d>] start_request+0x1b1/0x1d1     [<c023220f>] ide_do_request+0x2a0/0b
[<c023265e>] ide_intr+0xf3/0x11b     [<c023c1a7>] cdrom_read_intr+0x0/0x2a1
 [<c013632a>] handle_IRQ_event+0x23/0x4c     [<c01363cd>] __do_IRQ+0x7a/0xcd
 [<c01054d0>] do_IRQ+0x5c/0x77
 =======================
 [<c0103cea>] common_interrupt+0x1a/0x20     [<c0101120>] mwait_idle+0x1a/0x2e
 [<c01010a3>] cpu_idle+0x38/0x4d     [<c0390635>] start_kernel+0x17a/0x17c
Comment 1 Jeremy Katz 2006-01-05 15:52:40 EST
Obviously a test2 blocker
Comment 2 Rahul Sundaram 2006-01-07 05:31:42 EST
rawhide has switched to using AS by default now since CFQ results in slab
corruption according to today's report
Comment 3 Dave Jones 2006-01-11 23:43:30 EST
root cause now fixed. even elevator=cfq should work for test2, but to play it
safe, sticking with default=as for test2, rawhide has cfq again.

Note You need to log in before you can comment on or make changes to this bug.