Bug 1770584 - Add support for satellite 6.6 clone
Summary: Add support for satellite 6.6 clone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Satellite Clone
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 6.7.0
Assignee: satellite6-bugs
QA Contact: Vladimír Sedmík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-10 18:10 UTC by Nikhil Kathole
Modified: 2020-04-14 13:26 UTC (History)
3 users (show)

Fixed In Version: satellite-clone-1.5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1791507 (view as bug list)
Environment:
Last Closed: 2020-04-14 13:26:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:1454 None None None 2020-04-14 13:26:33 UTC

Description Nikhil Kathole 2019-11-10 18:10:45 UTC
Description of problem:

Add support for satellite 6.6 clone

# cat /usr/share/satellite-clone/library/parse_backup_metadata.py | grep SUPPORTED
SUPPORTED_VERSIONS = ["6.2", "6.3", "6.4", "6.5"]

Version-Release number of selected component (if applicable):
Satellite 6.7 snap 1

# rpm -q satellite-clone
satellite-clone-1.4.2-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. yum install satellite-clone
2. satellite-clone -y


Actual results:


Expected results:


Additional info: Bump new version with https://github.com/RedHatSatellite/satellite-clone/pull/365

Comment 3 Brad Buckingham 2019-11-15 19:15:38 UTC
Hi Jonathon,

I believe this work has been completed with [1].

Can you confirm?  Is there any additional work needed or should we move this one to POST?

Thanks!

[1] https://github.com/RedHatSatellite/satellite-clone/pull/365

Comment 4 Jonathon Turel 2019-11-15 19:50:31 UTC
This is completed, so moving to POST

Comment 5 Evgeni Golov 2019-11-19 09:34:11 UTC
While it is completed, there is no release containing this fix. Can you make a release happen please? :)

Comment 6 Brad Buckingham 2019-11-19 17:06:21 UTC
Added a card to our team board to request a new release.

Comment 7 Vladimír Sedmík 2019-12-06 18:14:57 UTC
Adding dependence on 1780727 as the restore must succeed first to ensure the cloning fully works for 6.6

Comment 11 errata-xmlrpc 2020-04-14 13:26:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:1454


Note You need to log in before you can comment on or make changes to this bug.