This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 177063 - Missing documentation for subversion 1.3.0
Missing documentation for subversion 1.3.0
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 16:32 EST by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 06:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2006-01-05 16:32:12 EST
Description of problem:
Subversion book is no longer there. Also, would it be possible to generate
Doxygen API docs and put them in subversion-devel package? It would be nice to
know what the API looks like without going through gazillion header files...


Version-Release number of selected component (if applicable):
1.3.0-2
Comment 1 Kenneth Porter 2006-01-09 22:08:55 EST
The book was moved to a separate repository upstream. Perhaps it makes sense to
move the book to Extras.
Comment 2 Joe Orton 2006-01-10 06:45:28 EST
The doxygen-generated docs come out at 6.4M unpacked, I really don't like adding
this stuff to packages, it's unnecessary bloat.  You can get it from a web site
somewhere just as easily.  Likewise for the book.
Comment 3 Bojan Smojver 2006-01-10 07:01:56 EST
If I find some time, I may submit subversion-docs package to Extras.
Comment 4 Bojan Smojver 2006-01-10 20:23:42 EST
I built subversion-api-docs "binary" package (see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177483) and it was 792400
bytes...
Comment 5 Joe Orton 2006-01-11 07:29:11 EST
Thanks a lot Bojan.  I think that's the way to go, it's nearly a megabyte of
precious CD space saved then!

Note You need to log in before you can comment on or make changes to this bug.