Bug 1770677 - description is empty when oc explain dnsrecords --api-version=ingress.operator.openshift.io/v1
Summary: description is empty when oc explain dnsrecords --api-version=ingress.operato...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 06:31 UTC by Hongan Li
Modified: 2020-05-04 11:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:15:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift api pull 584 None closed Bug 1770677: operator/ingress: add dnsrecord type 2020-10-08 14:26:53 UTC
Github openshift cluster-ingress-operator pull 360 None closed Bug 1770677: upstream the dnsrecord type 2020-10-08 14:26:53 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:15:34 UTC

Description Hongan Li 2019-11-11 06:31:40 UTC
Description of problem:
The description is empty when oc explain dnsrecords --api-version=ingress.operator.openshift.io/v1

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-10-185106

How reproducible:
100%

Steps to Reproduce:
1. $ oc explain dnsrecords --api-version=ingress.operator.openshift.io/v1
2.

Actual results:
KIND:     DNSRecord
VERSION:  ingress.operator.openshift.io/v1

DESCRIPTION:
     <empty>


Expected results:
description should not be empty.

Additional info:

Comment 1 Dan Mace 2019-11-11 15:35:44 UTC
This API is internal and so it won't a priority any time soon. For now I'll move it to a future release.

Comment 4 Hongan Li 2020-02-20 06:35:13 UTC
verified with 4.4.0-0.nightly-2020-02-19-155241 and issue has been fixed.

$ oc explain dnsrecords --api-version=ingress.operator.openshift.io/v1
KIND:     DNSRecord
VERSION:  ingress.operator.openshift.io/v1

DESCRIPTION:
     DNSRecord is a DNS record managed in the zones defined by
     dns.config.openshift.io/cluster .spec.publicZone and .spec.privateZone.
     Cluster admin manipulation of this resource is not supported. This resource
     is only for internal communication of OpenShift operators.

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object>
     spec is the specification of the desired behavior of the dnsecord.

   status	<Object>
     status is the most recently observed status of the dnsRecord.

Comment 6 errata-xmlrpc 2020-05-04 11:15:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.