Bug 177069 - bcm43xx fails to start (SIOCSIFFLAGS File not found)
bcm43xx fails to start (SIOCSIFFLAGS File not found)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 18:05 EST by Peter Quiring
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 15:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Quiring 2006-01-05 18:05:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
When bringing up the interface the following error msg is displayed:

SIOCSIFFLAGS : No such file or directory.
Failed to start wlan0.

I traced /etc/sysconfig/network-scripts/ifup-eth to the line:
if ! ip link set dev ${REALDEVICE} up
this is where the error occurs.

Hope this helps.

Thanks.



Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1819

How reproducible:
Always

Steps to Reproduce:
1.Install with 2.6.15 kernel
2.Start wlan0 interface.
3.
  

Actual Results:  Interface fails to start.

Expected Results:  Interface starts.

Additional info:

If set for dhcp, the error msg is displayed twice and then the scripts attempt to ping the gateway server but fails (it must be partially communicating if it knows the gateway in dhcp mode).
Comment 1 Peter Quiring 2006-01-08 19:24:49 EST
Should this bug be assigned to 'iproute' since that is the package that contains
the 'ip' app?  I've noticed that iproute version is 2.6.14 but the kernel is
2.6.15, does this mean we are waiting for the update to iproute?
Comment 2 David Woodhouse 2006-01-13 00:15:03 EST
You need the firmware -- the kernel messages should have made that clear.

Get the fwcutter tool from http://bcm43xx.berlios.de/ and extract the firmware
from your existing MacOS or Windows driver (or indeed any driver you can
download) with it.
Comment 3 David Woodhouse 2006-01-13 00:15:47 EST
ftp://ftp.berlios.de/pub/bcm43xx/snapshots/fwcutter/
Comment 4 Peter Quiring 2006-01-13 13:17:03 EST
In that case I'll stick with ndiswrapper.
Comment 5 Peter Quiring 2006-01-13 13:38:05 EST
I tried the fwcutter with mixed success.  DHCP doesn't work, and it only goes
upto 11M but seems to be stuck in 1M mode (very slow).

Thanks for the info, I'll keep trying with future releases of the kernel.

Comment 6 David Woodhouse 2006-01-13 13:43:38 EST
Yeah, the driver is fairly new and still under active development. DHCP is
likely to work if you do it in something like the following order...

1. ip link set eth1 up
2. Set rate to something that works (it doesn't automatically back down)
2. set the WEP key (if any)
3. set essid
4. dhclient

NetworkManager does manage to get it right, apart from the rate -- I just use
NetworkManager and then set the rate to 11M manually to make sure it doesn't
lose packets (which it does at 54M).
Comment 7 David Woodhouse 2006-03-22 11:05:01 EST
This should be improved in the 2.6.16-1.2070_FC5 kernel. 

Note You need to log in before you can comment on or make changes to this bug.