Bug 1770757 - Node maintenance percentage is incorrectly calculated when NMO isn't running
Summary: Node maintenance percentage is incorrectly calculated when NMO isn't running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 10:02 UTC by Jiri Tomasek
Modified: 2020-01-23 11:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When Node Maintenance Operator is not running and maintenance is started, the UI now correctly shows 0% progress.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3330 'None' 'closed' 'Bug 1770757: Display correct initial maintenance percentage' 2019-11-28 13:09:24 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:12:18 UTC

Description Jiri Tomasek 2019-11-11 10:02:35 UTC
Description of problem:
Node maintenance percentage is incorrectly calculated when NMO isn't running or hasn't touched the maintenance CR yet.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. While NMO is not running, in 'Bare Metal Hosts' section select one of the hosts and run 'Start node maintenance' action from the kebab action menu.
2. Click 'Starting maintenance' host status to show popover

Actual results:
Popover shows 100% maintenance progress

Expected results:
Popover shows 0% maintenance progress


Additional info:

Comment 5 errata-xmlrpc 2020-01-23 11:12:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.