Bug 1770841 - python3-mapnik fails to install in Fedora rawhide
Summary: python3-mapnik fails to install in Fedora rawhide
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mapnik
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tom Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-11-11 12:07 UTC by Miro Hrončok
Modified: 2020-02-11 17:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-11 12:07:39 UTC
python3-mapnik-0.1-48.20180723git588fc90.fc32.x86_64 fails to install in Fedora rawhide:

  package python3-mapnik-0.1-48.20180723git588fc90.fc32.x86_64 requires libmapnik.so.3.0()(64bit), but none of the providers can be installed
  nothing provides libproj.so.13()(64bit) needed by mapnik-3.0.22-6.fc31.x86_64
  nothing provides proj-epsg needed by mapnik-3.0.22-6.fc31.x86_64

Comment 1 Tom Hughes 2019-11-11 12:56:25 UTC
Yes I know but I can't rebuild mapnik until postgis has been rebuilt against the new libproj.

Maybe you should be complaining to the person that did an soname bump on proj without coordinating it...

Comment 2 Miro Hrončok 2019-11-11 13:05:02 UTC
I'm not complaining, I'm not blaming, I'm simply reporting a problem.

If you are unhappy about a particular way something was handled, I recommend trying to talk to the person who did it. Sometimes, they are simply unaware of all the consequences of their actions.

Comment 3 Ben Cotton 2020-02-11 17:46:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.


Note You need to log in before you can comment on or make changes to this bug.