Bug 177085 - The kernel prints repeated messages about unknown keyboard release codes
Summary: The kernel prints repeated messages about unknown keyboard release codes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-06 03:13 UTC by Alistair Riddoch
Modified: 2015-01-04 22:24 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-16 05:25:02 UTC


Attachments (Terms of Use)

Description Alistair Riddoch 2006-01-06 03:13:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
At some point during boot the following messages start being output by the kernel
onto the console, and into the syslog:

Jan  6 02:54:28 click kernel: atkbd.c: Unknown key released (translated set 2, code 0x7f on isa0060/serio0).
Jan  6 02:54:28 click kernel: atkbd.c: Use 'setkeycodes 7f <keycode>' to make it known.

The machine in question does not have an AT keyboard attached, but uses a USB keyboard instead.

Version-Release number of selected component (if applicable):
2.6.14-1.1805_FC5

How reproducible:
Always

Steps to Reproduce:
1. Boot the system with kernel 2.6.14-1.1805_FC5
  

Actual Results:  atkdb.c error messages are printed once per second.

Expected Results:  No such messages should be printed.


Additional info:

Comment 1 Alistair Riddoch 2006-01-06 03:28:32 UTC
Also confirmed with kernel-2.6.15-1.1819_FC5, and confirmed that the messages
begin as soon as the kernel has started.

Comment 2 Dan Carpenter 2006-01-06 05:07:24 UTC
http://lists.parisc-linux.org/hypermail/parisc-linux-cvs/4887.html

maybe try adding:
setkeycodes 7f 86
to /etc/rc.local

Comment 3 Pete Zaitcev 2006-01-06 05:37:42 UTC
This is a BIOS emulation acting up. Best of all is to switch it off
in BIOS setup (sometimes called "USB Legacy"). The FC5 should have
default usb-handoff by now, which should accomplish the same effect,
but for some reason it didn't work here.


Comment 4 Alistair Riddoch 2006-02-04 12:18:47 UTC
I am no longer seeing this problem with recent kernels from development.
The issue is resolved.


Note You need to log in before you can comment on or make changes to this bug.