Bug 177092 - Font details not displayed when a Type 1 font is Double-clicked
Font details not displayed when a Type 1 font is Double-clicked
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 23:48 EST by Chris Tyler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 21:35:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Tyler 2006-01-05 23:48:59 EST
Description of problem:
Then viewing installed fonts using the font:/ location in Nautilus,
double-clicking on a Type 1 font causes the Evince document viewer to be
launched instead of gnome-font-viewer when using FC5t1 or current Rawhide. The
correct behaviour is exhibited if a TrueType font is clicked, or if this action
is performed in FC4.

Version-Release number of selected component (if applicable):
nautilus-2.13.3-1

Steps to Reproduce:
1. Open the location fonts:/ in Nautilus.
2. Select a Type 1 font such as Bitstream Charter.

  
Actual results:
Evince will open with the message 'Unhandled MIME type: application/x-font-type-1'

Expected results:
gnome-font-viewer will be launched to preview the font (as is the case for TT
fonts, or Type 1 in FC4).

Additional info:
- Similar but not identical to bug 160909 which is marked "CLOSED-RAWHIDE"
(although the current rawhide build doesn't fix it).
- Probably a MIME-type issue more than a Nautilus problem.
Comment 1 Chris Tyler 2006-01-05 23:51:13 EST
It's possible to open the font in gnome-ghost-view by right-clicking and
selecting 'Open with "GNOME Font Viewer"'
Comment 2 Alexander Larsson 2006-01-12 10:46:08 EST
I think this is a mime info issue. Reassigning.
Comment 3 Rahul Sundaram 2006-02-20 06:11:40 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Chris Tyler 2006-02-21 21:35:07 EST
Fixed in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.