Bug 1770923 - [abrt] ESimpleAsyncResult: Avoid thread scheduling race when finishing on idle
Summary: [abrt] ESimpleAsyncResult: Avoid thread scheduling race when finishing on idle
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a7374b87f0b0a8f702eb59fe7b3...
: 1794026 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 13:56 UTC by ehespinosa
Modified: 2020-01-22 17:48 UTC (History)
6 users (show)

Fixed In Version: evolution-3.34.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-11 17:30:18 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (83.19 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: cgroup (195 bytes, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: core_backtrace (38.11 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: cpuinfo (1.62 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: dso_list (28.90 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: environ (3.67 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: limits (1.29 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: maps (177.78 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: mountinfo (3.82 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: open_fds (4.83 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details
File: proc_pid_status (1.32 KB, text/plain)
2019-11-11 13:56 UTC, ehespinosa
no flags Details

Description ehespinosa 2019-11-11 13:56:04 UTC
Description of problem:
I was reading e-mail with Evolution

Version-Release number of selected component:
evolution-3.32.4-1.fc30

Additional info:
reporter:       libreport-2.10.1
backtrace_rating: 4
cmdline:        evolution
crash_function: WebKit::CallbackMap::invalidate
executable:     /usr/bin/evolution
journald_cursor: s=dee50f4de4ed41bb9fb8941ef950caf4;i=9a5;b=a8bbda8605a64654bc3433a4a2376d7e;m=6baae391;t=5971204dd978e;x=533b11093e84bb3b
kernel:         5.3.8-200.fc30.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1003

Comment 1 ehespinosa 2019-11-11 13:56:09 UTC
Created attachment 1634875 [details]
File: backtrace

Comment 2 ehespinosa 2019-11-11 13:56:10 UTC
Created attachment 1634876 [details]
File: cgroup

Comment 3 ehespinosa 2019-11-11 13:56:13 UTC
Created attachment 1634877 [details]
File: core_backtrace

Comment 4 ehespinosa 2019-11-11 13:56:14 UTC
Created attachment 1634878 [details]
File: cpuinfo

Comment 5 ehespinosa 2019-11-11 13:56:16 UTC
Created attachment 1634879 [details]
File: dso_list

Comment 6 ehespinosa 2019-11-11 13:56:18 UTC
Created attachment 1634880 [details]
File: environ

Comment 7 ehespinosa 2019-11-11 13:56:19 UTC
Created attachment 1634881 [details]
File: limits

Comment 8 ehespinosa 2019-11-11 13:56:24 UTC
Created attachment 1634882 [details]
File: maps

Comment 9 ehespinosa 2019-11-11 13:56:25 UTC
Created attachment 1634883 [details]
File: mountinfo

Comment 10 ehespinosa 2019-11-11 13:56:27 UTC
Created attachment 1634884 [details]
File: open_fds

Comment 11 ehespinosa 2019-11-11 13:56:28 UTC
Created attachment 1634885 [details]
File: proc_pid_status

Comment 12 Milan Crha 2019-11-11 17:30:18 UTC
Thanks for a bug report. The backtrace shows that there had played its role thread scheduling, finishing just added idle callback before the dedicated thread, which added that callback. I fixed this upstream for Fedora 31 and rawhide with:

Created commit [1] in evo master (3.35.2+)
Created commit [2] in evo gnome-3-34 (3.34.2+)

[1] https://gitlab.gnome.org/GNOME/evolution/commit/b4fa5a751af94faba57461fd767d5d3517b22d4c
[2] https://gitlab.gnome.org/GNOME/evolution/commit/01cc3a399261df924842c31d6c417b56adcd6ef5

Comment 13 Milan Crha 2020-01-22 17:48:57 UTC
*** Bug 1794026 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.