Bug 1771003 - Deprovision bare metal host state is not reflected when host's node is in maintenance
Summary: Deprovision bare metal host state is not reflected when host's node is in mai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 16:48 UTC by Jiri Tomasek
Modified: 2020-01-23 11:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3341 'None' 'closed' 'Bug 1771003: Don''t show maintenance status when host is being deprovisioned' 2019-11-19 13:35:25 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:12:36 UTC

Description Jiri Tomasek 2019-11-11 16:48:41 UTC
Description of problem:
When host's node is in maintenance and host's de-provisioning starts, the deprovisioning status is not visible in host status because it is displaying the maintenance status. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start node maintenance from bare metal host or node associated with it.
2. Annotate host's machine with 'cluster.k8s.io/delete-machine':true to mark it for deletion
3. Scale down the machine set to trigger deprovisioning of the host

Actual results:
Host status is still shown as 'Under Maintenance'


Expected results:
Host status is shown as 'Deprovisioning'


Additional info:

Comment 4 errata-xmlrpc 2020-01-23 11:12:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.