Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Currently kdump-error-handler have:
dracut-kdump-error-handler.service:ExecStopPost=-/usr/bin/systemctl --fail --no-block default
Systemd try to start default target again when it exits. This may lead to infinite loop if kdump-error-handler exits by accident.
> From: "d.hatayama" <d.hatayama>
>
> I also checked the behavior when FAILURE_ACTION="exit" for in case, i.e.
> the situation where shutdown/halt/reboot doesn't work well for some reason
> even though it terminates with successful exit status.
> The result is infinite loop like:
>·
> kdump-capture.serviec pulls in emergency.target on failrue
> => emergency.target pulls in emergency.service
> => emergency.service isolates kdump-error-handler.service
> => kdump-error-handler.service isolates default.target (= initrd.target) on ExecStopPost=
> => initrd.target pulls in kdump-capture.service
>·
> I think there is a room to improve this design in another work.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (kexec-tools bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2020:4462