Bug 177138 - OOo Calc steals focus a couple of times during startup
OOo Calc steals focus a couple of times during startup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 11:52 EST by Evert Verhellen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1.1-5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 02:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 19976 None None None Never

  None (edit)
Description Evert Verhellen 2006-01-06 11:52:08 EST
Description of problem:
OpenOffice.org Calc steals focus a couple of times during startup when a file
name is passed as an argument on the command line. Because loading a large file
takes a considerable amount of time one can easily see this happening. Clicking
another window during this process to refocus and continue typing is dangerous
because when OOo steals focus one is actually typing in the spreadsheet. This
can lead to inadvertant data loss.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.1-143.2.1
metacity-2.12.1-1
Comment 1 Caolan McNamara 2006-01-11 11:06:00 EST
Funnilly enough I was looking at this issue recently and patched OOo to reduce
this problem. So should be much improved with 2.0.1.1-5.2
Comment 2 Evert Verhellen 2007-02-06 18:41:40 EST
Honestly, I don't agree with that. If you minimize OOo during startup, it will
still unminimize unwantedly and steal focus.

Version details:
openoffice.org-calc-2.0.4-5.5.10
compiz-0.0.13-0.32.20060817git.fc6
Comment 3 Caolan McNamara 2007-02-07 02:56:44 EST
yeah, I improved things, and then they dis-improved. It's a tricky problem, but
for 2.2.0 we believe that it's going to be sorted out.

http://www.openoffice.org/issues/show_bug.cgi?id=19976 So I have high hopes for
2.2.0 in FC-7 squashing this finally.

Note You need to log in before you can comment on or make changes to this bug.