Bug 1771431 - installer exit upon an installation from ignition files with customer subnets specified
Summary: installer exit upon an installation from ignition files with customer subnets...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: W. Trevor King
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-12 11:15 UTC by Johnny Liu
Modified: 2020-01-23 11:12 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2656 'None' 'closed' 'Bug 1771431: pkg/asset/installconfig/aws: Serialize region and subnets' 2019-11-20 12:25:31 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:12:32 UTC

Description Johnny Liu 2019-11-12 11:15:59 UTC
Description of problem:

Version-Release number of the following components:
# openshift-install version
openshift-install v4.3.0
built from commit 93c16db3508065d3de74e362cbf5281ef46ce3f7
release image registry.svc.ci.openshift.org/ocp/release@sha256:70f5199ac2b055bc04e84d13571f7cc1b5e2955302f7a35731960b0cfccb49ca


How reproducible:
Always

Steps to Reproduce:
1. create a install-config.yaml
2. copy it to demo4 and demo5 folder separately.
3. Run the following steps against demo4 folder
# openshift-install create ignition-configs --dir demo4
INFO Consuming Install Config from target directory 
# openshift-install create cluster --dir demo4
FATAL failed to fetch Terraform Variables: failed to generate asset "Terraform Variables": no subnets configured 

4. Run the following steps against demo5 folder
# openshift-install create cluster --dir demo5
INFO Consuming Install Config from target directory 
INFO Creating infrastructure resources...         


Actual results:
Step 4 is failed when installation is triggered from ignition files.
Step 5 is succeeded when installation is triggered from install-config.yaml file.

Expected results:
Step 4 is working well.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Johnny Liu 2019-11-14 05:45:55 UTC
Verified this bug with 4.3.0-0.nightly-2019-11-13-233341, and PASS.

Comment 4 errata-xmlrpc 2020-01-23 11:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.