Bug 1771446 - Unable to run rawhide cloud virtual machine
Summary: Unable to run rawhide cloud virtual machine
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-12 11:46 UTC by Pavel Březina
Modified: 2019-12-02 15:36 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-02 15:36:46 UTC
Type: Bug


Attachments (Terms of Use)
boot attempt 1 (19.83 KB, image/png)
2019-11-12 11:46 UTC, Pavel Březina
no flags Details
boot attempt 2 (20.51 KB, image/png)
2019-11-12 11:47 UTC, Pavel Březina
no flags Details
login attempt (7.55 KB, image/png)
2019-11-12 11:47 UTC, Pavel Březina
no flags Details

Description Pavel Březina 2019-11-12 11:46:51 UTC
Created attachment 1635297 [details]
boot attempt 1

I do not know which component to use so I'm reporting it against kernel as the machine does not seem to boot correctly.

I'm using the following Fedora Rawhide compose:
https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Cloud/x86_64/images/Fedora-Cloud-Base-Vagrant-Rawhide-20191109.n.1.x86_64.vagrant-libvirt.box

And trying to start virtual machine using vagrant and libvirt. However, the compose gets stuck for few minutes during boot (two screenshots attached). Then it gets to login, but providing credentials (vagrant:vagrant) gets it stuck again (screenshot attached) for a while, after few minutes the login fails.

vagrant waits on:
==> client: Creating image (snapshot of base box volume).
==> client: Creating domain with the following settings...
==> client:  -- Name:              sssd-test-suite_client
==> client:  -- Domain type:       kvm
==> client:  -- Cpus:              1
==> client:  -- Feature:           acpi
==> client:  -- Feature:           apic
==> client:  -- Feature:           pae
==> client:  -- Memory:            4092M
==> client:  -- Management MAC:    
==> client:  -- Loader:            
==> client:  -- Nvram:             
==> client:  -- Base box:          fedora-rawhide
==> client:  -- Storage pool:      sssd-test-suite
==> client:  -- Image:             /mnt/vm/pool-sssd-test-suite/sssd-test-suite_client.img (41G)
==> client:  -- Volume Cache:      default
==> client:  -- Kernel:            
==> client:  -- Initrd:            
==> client:  -- Graphics Type:     vnc
==> client:  -- Graphics Port:     -1
==> client:  -- Graphics IP:       127.0.0.1
==> client:  -- Graphics Password: Not defined
==> client:  -- Video Type:        cirrus
==> client:  -- Video VRAM:        9216
==> client:  -- Sound Type:	
==> client:  -- Keymap:            en-us
==> client:  -- TPM Path:          
==> client:  -- INPUT:             type=mouse, bus=ps2
==> client: Creating shared folders metadata...
==> client: Starting domain.
==> client: Waiting for domain to get an IP address...

Fedora 29-31 composes works well.

Steps to reproduce:
$ vagrant box add --name fedora-rawhide https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Cloud/x86_64/images/Fedora-Cloud-Base-Vagrant-Rawhide-20191109.n.1.x86_64.vagrant-libvirt.box

$ cat Vagrantfile
Vagrant.configure("2") do |config|
  config.vm.box = "fedora-rawhide"
end

$ vagrant up
Bringing machine 'default' up with 'libvirt' provider...
==> default: Creating image (snapshot of base box volume).
==> default: Creating domain with the following settings...
==> default:  -- Name:              vm-test_default
==> default:  -- Domain type:       kvm
==> default:  -- Cpus:              1
==> default:  -- Feature:           acpi
==> default:  -- Feature:           apic
==> default:  -- Feature:           pae
==> default:  -- Memory:            512M
==> default:  -- Management MAC:    
==> default:  -- Loader:            
==> default:  -- Nvram:             
==> default:  -- Base box:          fedora-rawhide
==> default:  -- Storage pool:      default
==> default:  -- Image:             /mnt/vm/qemu/vm-test_default.img (41G)
==> default:  -- Volume Cache:      default
==> default:  -- Kernel:            
==> default:  -- Initrd:            
==> default:  -- Graphics Type:     vnc
==> default:  -- Graphics Port:     -1
==> default:  -- Graphics IP:       127.0.0.1
==> default:  -- Graphics Password: Not defined
==> default:  -- Video Type:        cirrus
==> default:  -- Video VRAM:        9216
==> default:  -- Sound Type:	
==> default:  -- Keymap:            en-us
==> default:  -- TPM Path:          
==> default:  -- INPUT:             type=mouse, bus=ps2
==> default: Creating shared folders metadata...
==> default: Starting domain.
==> default: Waiting for domain to get an IP address...

Comment 1 Pavel Březina 2019-11-12 11:47:17 UTC
Created attachment 1635298 [details]
boot attempt 2

Comment 2 Pavel Březina 2019-11-12 11:47:42 UTC
Created attachment 1635299 [details]
login attempt

Comment 3 Dusty Mabe 2019-11-21 15:58:03 UTC
Thanks for opening the issue. I think this could be related to the fact that the
cloud images are having trouble booting at all right now. See 
https://bugzilla.redhat.com/show_bug.cgi?id=1754471

Once that fix is in let's retry booting in vagrant.

Comment 4 Dusty Mabe 2019-12-02 15:36:46 UTC
I think this is fixed now since https://bugzilla.redhat.com/show_bug.cgi?id=1754471 and https://bugzilla.redhat.com/show_bug.cgi?id=1775882 are fixed.


Note You need to log in before you can comment on or make changes to this bug.