Bug 177148 - Switching init levels attempts to restart avahi daemon when already running
Switching init levels attempts to restart avahi daemon when already running
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 12:57 EST by Stephen Warren
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-12 13:08:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2006-01-06 12:57:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
If I type the following at a console:

telinit 3
  # wait
telinit 5
  # wait

and so on, each time, the system attempts to start the "Avahi daemon", which fails with messages such as:

Starting Avahi daemon... Daemon already running on PID 4103   [FAILED]


Version-Release number of selected component (if applicable):
avahi-0.6.1-3

How reproducible:
Always

Steps to Reproduce:
1. telinit 3
2. Watch console messages
3. telinit 5
4. Watch console messages


Actual Results:  See error message about Avahi already running.

Expected Results:  The system probably shouldn't even attempt to start Avahi, since it's presumably already running

Additional info:
Comment 1 Jason Vas Dias 2006-01-09 11:02:08 EST
This happens with every chkconfig service - when switching runlevels, chkconfig
tries to 'start' every service in the next run-level - it is up to the initscripts
to check if the service is already running and not start it if so - some scripts
emit error messages when this occurs, some do not.
chkconfig needs to ensure that when switching to a new runlevel, every service
meant to be running in that run level is running, regardless of any actions
the user may have taken to manually shut down a service.
Hence, this is NOTABUG - thanks for the report.

 
Comment 2 Stephen Warren 2006-01-09 11:48:12 EST
Actually, this is a bug! The Avahi scripts shouldn't be attempting to restart
the Avahi daemon if it's already running.

My expected behaviour is way every single other init script works - I don't get
error messages being spewed from every component that's active in both init
level 3 and 5 when doing "telinit 3" - just Avahi.

And if you still don't believe it's a bug - this bug report was triggered
because the hplip package had the same issue, and it was fixed because it was
considered a bug. See bug 173049 (the bug description is a little bogus - follow
the chain of comments)
Comment 3 Jason Vas Dias 2006-01-09 14:46:23 EST
OK, this is now fixed with avahi-0.6.3-1 .
Comment 4 Lennart Poettering 2007-08-12 13:08:01 EDT
I think this can be closed now.

Note You need to log in before you can comment on or make changes to this bug.