Bug 1771526 - fcitx input method is not working with default shell zsh
Summary: fcitx input method is not working with default shell zsh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-12 14:36 UTC by djraymond1
Modified: 2020-01-12 01:41 UTC (History)
2 users (show)

Fixed In Version: imsettings-1.8.2-1.fc30 imsettings-1.8.2-1.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-11 01:09:31 UTC
Type: Bug


Attachments (Terms of Use)
Found a log file, attach. (12.38 KB, text/plain)
2019-11-12 21:59 UTC, djraymond1
no flags Details

Description djraymond1 2019-11-12 14:36:45 UTC
Description of problem:

Happening after changing default shell from bash to zsh.

fcitx always shows up no input window. So that, I can't change my input language.

Setting default shell as zsh made fcitx not working.
This seems like happening like this : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=905129

I searched for of it, and found that zsh does not allow "for", so there was a same problem on ubuntu im-config, before version 0.36
This problem looks very similar to it.


After few minutes using my computer, I got a message: 
Giving up to bring the process up because main Input Method process for FCITX rapidly died many times. See $XDG_CACHE_HOME/imsettings/log for more details.
(...and I couldn't find the log file)


I've checked and tried to add export ~~~ on .zshrc, and it's same. This was same as ubuntu im-config what I've mentioned before.

Version-Release number of selected component (if applicable):
imsettings               x86_64     1.8.1-2.fc31
fcitx                    x86_64     4.2.9.6-6.fc31
(fcitx-hangul             x86_64     0.3.1-7.fc31)
zsh          x86_64          5.7.1-4.fc31

How reproducible:All


Steps to Reproduce:
1.Install fcitx + your language of fcitx, set it up
2.change shell from bash to zsh
3.restart computer, it happens.

Actual results:
Cannot change language, No input Window, seems export not working.


Expected results:Just works well


Additional info:
Using KDE Plasma workspace.

Comment 1 djraymond1 2019-11-12 21:59:07 UTC
Created attachment 1635511 [details]
Found a log file, attach.

Attaching the log file that contains 
Giving up to bring the process up because main Input Method process for FCITX rapidly died many times. See $XDG_CACHE_HOME/imsettings/log for more details.

Comment 2 Fedora Update System 2019-12-25 06:50:26 UTC
FEDORA-2019-b370ef6421 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b370ef6421

Comment 3 Fedora Update System 2019-12-25 06:50:57 UTC
FEDORA-2019-0b16b7a9b7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0b16b7a9b7

Comment 4 Fedora Update System 2020-01-03 21:32:24 UTC
imsettings-1.8.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b370ef6421

Comment 5 Fedora Update System 2020-01-04 22:23:13 UTC
imsettings-1.8.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0b16b7a9b7

Comment 6 Fedora Update System 2020-01-11 01:09:31 UTC
imsettings-1.8.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-01-12 01:41:33 UTC
imsettings-1.8.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.