Bug 177165 - modclusterd: Allow kids to gracefully exit
modclusterd: Allow kids to gracefully exit
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stanko Kupcevic
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 15:14 EST by Lon Hohberger
Modified: 2009-04-16 18:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 13:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2006-01-06 15:14:12 EST
Description of problem:

(this isn't an rgmanager problem, actually - but there's no BZ entry for clumond
yet...)

clumond forks children and waits (currently), 3000ms (3 seconds) for those
applications to complete.  Under many circumstances, it may take >3sec for them
to complete, and it's perfectly reasonable to kill them if we're on a time
schedule.  It is probably better, however, to kill them with SIGINT or SIGTERM
prior to sending them SIGKILL so they have a chance to clean up.

One particular instance where this has become a problem is when using clustat: 
clustat opens a connection descriptor to ccsd, which is persistent until closed.
 If clustat is taking to long to complete (which is often), a ccsd connection
descriptor is leaked.  If ccsd runs out of connection descriptors, nothing will
be able to configure/reconfigure, and this message will appear in the logs:

"Error while processing connect: Resource temporarily unavailable"


Version-Release number of selected component (if applicable): CVS/Head


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stanko Kupcevic 2006-01-09 11:27:09 EST
Server shouldn't misbehave no matter what client does, so this is a ccsd's bug,
too. 
CC jbrassow@redhat.com

Clumond should be a good resident and issue SIGINT or SIGTERM before SIGKILL;
will fix.
Comment 2 Stanko Kupcevic 2006-10-03 13:52:41 EDT
Since server side has been fixed, this issue is a non-issue any more. 

Note You need to log in before you can comment on or make changes to this bug.