Bug 1771843 - No prometheus graph for firing alerts except Watchdog
Summary: No prometheus graph for firing alerts except Watchdog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Andrew Pickering
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-13 06:41 UTC by Junqi Zhao
Modified: 2020-06-18 19:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1823261 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:12:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
only watchdog alert has prometheus graph (75.99 KB, image/png)
2019-11-13 06:41 UTC, Junqi Zhao
no flags Details
alert other than Watchdog does not show prometheus graph (85.19 KB, image/png)
2019-11-13 06:42 UTC, Junqi Zhao
no flags Details
alert other than Watchdog is showing prometheus graph (4.4) (132.40 KB, image/png)
2020-04-13 18:32 UTC, David Taylor
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3445 'None' closed Bug 1771843: Monitoring: Fix alert details page graphs 2020-06-18 19:11:04 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:12:32 UTC

Description Junqi Zhao 2019-11-13 06:41:17 UTC
Created attachment 1635628 [details]
only watchdog alert has prometheus graph

Description of problem:
Except Watchdog alerts, there are other alerts under "Monitoring -> Alerting", but only Watchdog alert has prometheus graph, other alerts don't have prometheus graph

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-12-043446

How reproducible:
Always

Steps to Reproduce:
1. "Monitoring -> Alerting",c lick firing alerts to check prometheus graph
2.
3.

Actual results:
No prometheus graph for firing alerts except Watchdog

Expected results:
Should have graph for all alerts

Additional info:

Comment 1 Junqi Zhao 2019-11-13 06:42:49 UTC
Created attachment 1635629 [details]
alert other than Watchdog does not show prometheus graph

Comment 5 Viacheslav 2019-11-19 15:28:01 UTC
Fixed.
4.3.0-0.nightly-2019-11-19-053808

Comment 8 errata-xmlrpc 2020-01-23 11:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062

Comment 9 David Taylor 2020-04-13 18:32:28 UTC
Created attachment 1678500 [details]
alert other than Watchdog is showing prometheus graph (4.4)

Comment 10 David Taylor 2020-04-13 18:34:07 UTC
Comment on attachment 1678500 [details]
alert other than Watchdog is showing prometheus graph (4.4)

Please ignore, I updated wrong bug

Comment 11 Samuel Padgett 2020-06-18 19:11:34 UTC
*** Bug 1825137 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.