Bug 177185 - Installer does not detect or install to external USB Drive
Installer does not detect or install to external USB Drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 21:31 EST by Cody DeHaan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 11:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cody DeHaan 2006-01-06 21:31:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)

Description of problem:
When attempting to install Fedora Core 4, it will not detect my USB Hard Drive so I can install to it. The BIOS is able to boot off the drive, so the drive is not the issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Plug in USB Drive
2. Start install
3. Notice lack of USB Drive in partition configuration
  

Actual Results:  Drive does not show up.

Expected Results:  Ubuntu, for example, mounts the USB drive as a SCSI device and sucessfully installs and runs off of the USB drive.

Additional info:

Dell D800 laptop, Maxtor USB 2.0 Hard drive with 50GB NTFS, and 50GB free space.
Comment 1 Jeremy Katz 2006-01-18 11:12:30 EST
Installing to external USB drives isn't supported as there are a lot of
complications around boot loading there.
Comment 2 David Timms 2006-01-30 07:24:22 EST
jeremy: what about when the bios actually supports booting from the external usb
disk? (starting to become fairly common these days with current hardware).
Is there no way to do for example a test install to your external (80G) USB
disk, set your bios to boot from it, and not mess with the notebook/pc's other
operating systems ?

Would it be fair to provide a dialog along the lines:
"Booting from a USB drive requires special support from the PC's BIOS. It is not
currently possible to detect whether your PC meets this functionality. Only
continue this installation if you are sure that your PC is capable of booting
from the USB drive" ??
---
I know I wished it worked when my notebook PC failed (but not the hard disk); I
seriously needed data of the disk. Being able to put the drive in a USB disk
caddy, and then be able to boot the disk using any other PC (whose BIOS supports
USB disk boot) would have been a real time (life) saver.
---
Are there further issues that you can list ?
Comment 3 sidlon 2006-02-27 10:11:13 EST
This specific bug (the detection & display of the USB drive during install) is 
currently fixed in FC4.  It is now possible to go through the full install 
process, partioning & installing onto an external drive.

Booting however is still an issue, apparently because the default initrd image 
doesn't contain the required usb-storage module.  The current work-around is 
nicely detailed at http://www.vigla.eclipse.co.uk.  From what I can tell, it 
seems that every major linux distribution requires this workaround.

If this fix is as simple as adding a module to the default initrd image, then I 
think it would be in RedHat's best interests to become the first distro (to my 
knowledge) to be easily installable to external drives.  This would make it 
much easier for newcomers to test the linux waters without interfering with an 
existing Windows install.

I hope that this can become a priority in future revisions.


Note You need to log in before you can comment on or make changes to this bug.