Bug 1771851 - Console does not allow git repository with port defined
Summary: Console does not allow git repository with port defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-13 07:00 UTC by Jaspreet Kaur
Modified: 2020-01-23 11:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Import from Git form used a regular expression to validate the Git URL. Unfortunately it was too restrictive and disallowed certain URLs which are actually valid. Consequence: The user could not enter what they considered to be a valid Git URL and complete the form. Fix: The Git URL regular expression used for validation has been updated. Result: All valid Git URLs are now accepted.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:12:53 UTC

Description Jaspreet Kaur 2019-11-13 07:00:38 UTC
Description of problem:When trying to do a from git deployment in the console it does not allow any git repositories that contain a port number such as "https://example.com:3000/app.git". There is an error message "Invalid Git URL." displayed.

It works just fine through the CLI.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: Invalid git url


Expected results: should work if it is working with cli


Additional info:

Comment 4 cvogt 2019-11-16 01:06:36 UTC
Related to https://bugzilla.redhat.com/show_bug.cgi?id=1766350

There's issues with the git url validation regex.

Comment 5 cvogt 2019-11-19 15:02:23 UTC
PR: https://github.com/openshift/console/pull/3429

Comment 7 errata-xmlrpc 2020-01-23 11:12:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.