Bug 177189 - selecting entry from address book has no effect
selecting entry from address book has no effect
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: linphone (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 22:32 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 06:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-01-06 22:32:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
If you open the address book, click on an entry and then on the Select button, earlier versions of linphone would fill in the `Sip address:' portion of the main screen.  Ditto for selecting an entry in `My online friends'.  With the latest build for FC5 devel, none of this happens, and instead you get errors logged to the terminal from which linphone was started.  This worked fine on the previous build on both x86_64 and i386.

Version-Release number of selected component (if applicable):
linphone-1.2.0-1.fc5

How reproducible:
Always

Steps to Reproduce:
1.Open the address book
2.Click on an entry
3.Click on the Select button

Actual Results:  Nothing.  Well, actually, the following messages appeared on the terminal:

(linphone:32232): GLib-GObject-WARNING **: invalid cast from `GtkEntry' to `GnomeEntry'
(linphone:32232): GnomeUI-CRITICAL **: gnome_entry_gtk_entry: assertion `GNOME_IS_ENTRY (gentry)' failed
(linphone:32232): Gtk-CRITICAL **: gtk_entry_set_text: assertion `GTK_IS_ENTRY (entry)' failed


Expected Results:  It should have transferred the sip address of the selection to the `Sip address:' portion of the main screen

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-01-12 06:04:54 EST
Upstream claims that it will be fixed in 1.2.1.
Comment 2 Ignacio Vazquez-Abrams 2006-01-24 21:44:35 EST
I got tired of waiting for upstream.
Comment 3 Alexandre Oliva 2006-02-03 17:47:51 EST
Thanks, I confirm that fixed it.

Note You need to log in before you can comment on or make changes to this bug.