Bug 1772008 (CVE-2019-14887) - CVE-2019-14887 wildfly: The 'enabled-protocols' value in legacy security is not respected if OpenSSL security provider is in use
Summary: CVE-2019-14887 wildfly: The 'enabled-protocols' value in legacy security is n...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-14887
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1768980
TreeView+ depends on / blocked
 
Reported: 2019-11-13 12:24 UTC by Kunjan Rathod
Modified: 2020-06-11 07:17 UTC (History)
84 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found when an OpenSSL security provider is used with Wildfly, the 'enabled-protocols' value in the Wildfly configuration isn't honored. An attacker could target the traffic sent from Wildfly and downgrade the connection to a weaker version of TLS, potentially breaking the encryption. This could lead to a leak of the data being passed over the network.
Clone Of:
Environment:
Last Closed: 2020-03-12 22:31:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:0804 None None None 2020-03-12 17:04:36 UTC
Red Hat Product Errata RHSA-2020:0805 None None None 2020-03-12 17:06:09 UTC
Red Hat Product Errata RHSA-2020:0806 None None None 2020-03-12 17:01:41 UTC
Red Hat Product Errata RHSA-2020:0811 None None None 2020-03-12 17:00:42 UTC
Red Hat Product Errata RHSA-2020:0951 None None None 2020-03-23 20:13:57 UTC
Red Hat Product Errata RHSA-2020:0961 None None None 2020-03-24 11:13:49 UTC
Red Hat Product Errata RHSA-2020:0962 None None None 2020-03-24 11:38:48 UTC
Red Hat Product Errata RHSA-2020:2067 None None None 2020-05-18 10:27:18 UTC
Red Hat Product Errata RHSA-2020:2333 None None None 2020-05-28 15:59:34 UTC
Red Hat Product Errata RHSA-2020:2511 None None None 2020-06-10 19:05:51 UTC
Red Hat Product Errata RHSA-2020:2512 None None None 2020-06-11 07:17:09 UTC
Red Hat Product Errata RHSA-2020:2513 None None None 2020-06-11 07:08:46 UTC
Red Hat Product Errata RHSA-2020:2515 None None None 2020-06-10 19:24:07 UTC

Description Kunjan Rathod 2019-11-13 12:24:34 UTC
It was found that the OpenSSL security provider does not honor TLS version in 'enabled-protocols' value of Wildfly's legacy security configuration. An attacker could target traffic sent over a TLS connection with a weaker version of TLS and potentially break the encryption of the data stream.

Comment 8 Eric Christensen 2019-11-26 20:27:17 UTC
Mitigation:

Avoid using an OpenSSL security provider and instead use the default configuration or regular JSSE provider with 'TLS'.

Comment 12 Kunjan Rathod 2019-12-11 20:24:11 UTC
This vulnerability is out of security support scope for the following products:
 * Red Hat JBoss Operations Network 3
 * Red Hat JBoss Data Virtualization & Services 6
 * Red Hat JBoss Fuse 6
 * Red Hat JBoss SOA Platform 5

Please refer to https://access.redhat.com/support/policy/updates/jboss_notes for more details.

Comment 15 errata-xmlrpc 2020-03-12 17:00:38 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform

Via RHSA-2020:0811 https://access.redhat.com/errata/RHSA-2020:0811

Comment 16 errata-xmlrpc 2020-03-12 17:01:37 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 8

Via RHSA-2020:0806 https://access.redhat.com/errata/RHSA-2020:0806

Comment 17 errata-xmlrpc 2020-03-12 17:04:32 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 6

Via RHSA-2020:0804 https://access.redhat.com/errata/RHSA-2020:0804

Comment 18 errata-xmlrpc 2020-03-12 17:06:05 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.2 for RHEL 7

Via RHSA-2020:0805 https://access.redhat.com/errata/RHSA-2020:0805

Comment 19 Product Security DevOps Team 2020-03-12 22:31:59 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-14887

Comment 21 errata-xmlrpc 2020-03-23 20:13:53 UTC
This issue has been addressed in the following products:

  Red Hat Single Sign-On

Via RHSA-2020:0951 https://access.redhat.com/errata/RHSA-2020:0951

Comment 22 errata-xmlrpc 2020-03-24 11:13:37 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform

Via RHSA-2020:0961 https://access.redhat.com/errata/RHSA-2020:0961

Comment 23 errata-xmlrpc 2020-03-24 11:38:39 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7
  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6
  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8

Via RHSA-2020:0962 https://access.redhat.com/errata/RHSA-2020:0962

Comment 25 errata-xmlrpc 2020-05-18 10:27:13 UTC
This issue has been addressed in the following products:

  Red Hat Openshift Application Runtimes

Via RHSA-2020:2067 https://access.redhat.com/errata/RHSA-2020:2067

Comment 26 errata-xmlrpc 2020-05-28 15:59:30 UTC
This issue has been addressed in the following products:

  EAP-CD 19 Tech Preview

Via RHSA-2020:2333 https://access.redhat.com/errata/RHSA-2020:2333

Comment 27 errata-xmlrpc 2020-06-10 19:05:47 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6

Via RHSA-2020:2511 https://access.redhat.com/errata/RHSA-2020:2511

Comment 28 errata-xmlrpc 2020-06-10 19:24:03 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform

Via RHSA-2020:2515 https://access.redhat.com/errata/RHSA-2020:2515

Comment 29 errata-xmlrpc 2020-06-11 07:08:42 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8

Via RHSA-2020:2513 https://access.redhat.com/errata/RHSA-2020:2513

Comment 30 errata-xmlrpc 2020-06-11 07:17:05 UTC
This issue has been addressed in the following products:

  Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7

Via RHSA-2020:2512 https://access.redhat.com/errata/RHSA-2020:2512


Note You need to log in before you can comment on or make changes to this bug.