Bug 1772332 - Compliance reports Selection for deletion doesn't work as expected.
Summary: Compliance reports Selection for deletion doesn't work as expected.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-14 07:42 UTC by Jameer Pathan
Modified: 2021-01-19 21:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-19 21:34:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 28265 Normal New Compliance reports Selection for deletion doesn't work as expected. 2020-11-23 05:55:27 UTC
Red Hat Bugzilla 1772323 medium CLOSED Unable to delete SCAP reports from Satellite UI 2021-01-20 06:05:38 UTC

Internal Links: 1772323

Description Jameer Pathan 2019-11-14 07:42:53 UTC
Description of problem:
Compliance reports Selection for deletion doesn't work as expected.

Version-Release number of selected component (if applicable):
- Satellite 6.7.0 Snap 1
- tfm-rubygem-foreman_openscap-2.0.0-1.fm1_24.el7sat.noarch
- openscap-1.2.17-4.el7.x86_64

How reproducible:
Always

Steps to Reproduce:

1. Generate few SCAP reports.
2. Go to Hosts > Reports
3. Select reports to be deleted.
4. Click on 'Delete reports' button.

Actual results:
On Firefox version 60.6.1.
- All reports get selected for deletion.

On Chrome Version 75.0.3770.100 (Official Build) (64-bit)
- Two extra reports appears no actual deletion page.



Expected results:
- no. of reports selected for deletion should match 
with the no. of reports shown on actual deletion page.


Additional info:

Comment 5 Ondřej Pražák 2019-11-14 10:10:10 UTC
Created redmine issue https://projects.theforeman.org/issues/28265 from this bug

Comment 6 Ondřej Pražák 2019-11-14 10:13:42 UTC
Workaround:
1) check select all in the table header
2) check deselect all
3) select the reports you want to delete

Comment 7 Jameer Pathan 2019-11-14 10:24:45 UTC
Thanks Ondřej, workaround you mentioned in comment6 solves the problem.

Comment 8 Ondřej Pražák 2019-11-26 14:12:03 UTC
I know this is an annoying issue, but I'd like to move this out of 6.7. The core problem lies in how the table selection is implemented, any changes to this feature are likely to cause more problems. The proper fix it to transition to a reliable implementation using our new js stack, which will not happen in 6.7 time frame.

Comment 12 Mike McCune 2020-12-09 22:18:08 UTC
Upon review of our valid but aging backlog the Satellite Team has concluded that this Bugzilla does not meet the criteria for a resolution in the near term, and are planning to close in approximately a month. If you have any concerns about this, please contact your Red Hat Account team.  Thank you.

Comment 13 Mike McCune 2021-01-19 21:27:26 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.