Bug 1772346 - Failed to display the InstallPlan on the Web console if use manual way
Summary: Failed to display the InstallPlan on the Web console if use manual way
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1773708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-14 08:24 UTC by Jian Zhang
Modified: 2020-01-23 11:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3316 0 'None' closed Bug 1767072: Fix catalog source links in install plan details 2020-04-03 09:23:04 UTC
Github openshift console pull 3453 0 'None' closed Bug 1772346: Fix InstallPlan link on Subscription page 2020-04-03 09:23:04 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:13:03 UTC

Description Jian Zhang 2019-11-14 08:24:40 UTC
Description of problem:
Failed to display the InstallPlan, the users cannot approve it on the Web console. See a screenshot: https://user-images.githubusercontent.com/15416633/68838701-1f017000-06fa-11ea-8781-a9cd35224fe0.png

Version-Release number of selected component (if applicable):
Cluster version is 4.3.0-0.nightly-2019-11-13-233341

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.3.
2. Install the etcd-operator with the Manual way on the Web console.


Actual results:
Failed to approve it since it's not displayed.

Expected results:
The users can approve the InstallPlan objects on the Web console.

Additional info:
It can be approval successfully in the backend, see below:
mac:~ jianzhang$ oc get sub 
NAME             PACKAGE          SOURCE                CHANNEL
etcd             etcd             community-operators   singlenamespace-alpha
mac:~ jianzhang$ oc get ip
NAME            CSV                     APPROVAL    APPROVED
install-xvxjd   etcdoperator.v0.9.4     Manual      false
mac:~ jianzhang$ oc edit ip install-xvxjd 
installplan.operators.coreos.com/install-xvxjd edited
mac:~ jianzhang$ oc get csv
NAME                                        DISPLAY                  VERSION              REPLACES                PHASE
etcdoperator.v0.9.4                         etcd                     0.9.4                etcdoperator.v0.9.2     Succeeded
mac:~ jianzhang$ oc get pods
NAME                              READY   STATUS    RESTARTS   AGE
etcd-operator-6d457f8495-5gzkx    3/3     Running   0          57s

Comment 1 Samuel Padgett 2019-11-14 13:31:49 UTC
There's not enough detail here to reproduce. What do you mean "the manual way"? Can you give precise steps?

Can you include the InstallPlan YAML?

Comment 2 Jian Zhang 2019-11-15 02:54:54 UTC
Samuel,

The "manual way" means the Manual Approval Strategy, see the screenshot:
https://user-images.githubusercontent.com/15416633/68913385-1494b400-0796-11ea-8efc-717b60c13a32.png

Comment 3 Samuel Padgett 2019-11-18 19:44:26 UTC
*** Bug 1773708 has been marked as a duplicate of this bug. ***

Comment 4 Samuel Padgett 2019-11-18 19:46:46 UTC
https://github.com/openshift/console/pull/3453 fixes the link not showing up on the Subscription tab

https://github.com/openshift/console/pull/3316 fixes the InstallPlan page not being registered

Comment 6 Jian Zhang 2019-11-22 02:43:17 UTC
Cluster version is 4.3.0-0.nightly-2019-11-21-122827

It works well, I can see the InstallPlan and approve it on the Web console. LGTM, verify it. See the screenshots:
https://user-images.githubusercontent.com/15416633/69393576-86c84400-0d14-11ea-87ac-50deb60f98a6.png
https://user-images.githubusercontent.com/15416633/69393593-921b6f80-0d14-11ea-8e72-962fc65f3d01.png

Comment 8 errata-xmlrpc 2020-01-23 11:12:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.