Bug 1772451 - etcd: client bump to 3.3.17
Summary: etcd: client bump to 3.3.17
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-14 11:49 UTC by Sam Batschelet
Modified: 2020-01-23 11:13 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24149 'None' 'closed' 'Bug 1772451: vendor: bump etcd, bbolt and gRPC-go' 2019-11-29 18:19:03 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:03 UTC

Description Sam Batschelet 2019-11-14 11:49:47 UTC
Description of problem:

After etcd v3.3.15 was released a few major bugs were exposed and were patched through v3.3.17. The bump to etcd was part of kube 1.16.3 but as OpenShift is pinned to 1.16.2 these changes should be introduced by a dependency bump for etcd and bbolt.

- "etcd client does not parse IPv6 addresses correctly when members are joining" [1] fixed via [2]
- "kube-apiserver: failover on multi-member etcd cluster fails certificate check on DNS mismatch" [3] fixed via [4]

[1] kubernetes/kubernetes#83550
[2] https://github.com/etcd-io/etcd/pull/11211
[3] kubernetes/kubernetes#83028
[4] https://github.com/etcd-io/etcd/pull/11184


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: etcd client version is paired with etcd server


Additional info:

Comment 2 ge liu 2019-11-18 08:07:29 UTC
Verified with 4.3.0-0.nightly-2019-11-17-224250, etcdctl version updated to 3.3.17

Comment 4 errata-xmlrpc 2020-01-23 11:12:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.