Bug 1772466 - Createrepo_c UpdateRecord ignores reboot_suggested at advisory level
Summary: Createrepo_c UpdateRecord ignores reboot_suggested at advisory level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: createrepo_c
Version: 8.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 8.0
Assignee: amatej
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-14 12:33 UTC by Pavel Picka
Modified: 2020-04-28 15:39 UTC (History)
1 user (show)

Fixed In Version: createrepo_c-0.15.1-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 15:39:34 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1620 0 None None None 2020-04-28 15:39:41 UTC

Description Pavel Picka 2019-11-14 12:33:43 UTC
Description of problem:
Createrepo_c ignores "reboot_suggested" on advisory level, (not to confuse with support on package level).
E.g. You can find this type of advisory in rhel7 os repositories.
It is critical to get it to the upstream createrepo_c as soon as possible.

  <update status="final" from="release-engineering@redhat.com" version="4" type="bugfix">
    <id>RHBA-xxxx:xxxx</id>
 => <reboot_suggested>True</reboot_suggested> 
    <references>...</references>
    <pkglist>...</pkglist>
    

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. rec = cr.UpdateRecord()
2. rec.reboot_suggested = True

Actual results:
no support

Expected results:
Can parse and generate 'reboot_suggested' on advisory level with createrepo_c for UpdateRecord.

Comment 1 amatej 2019-12-03 08:40:06 UTC
I have created a PR: https://github.com/rpm-software-management/createrepo_c/pull/187

Comment 2 amatej 2019-12-04 08:47:59 UTC
I have updated the current unit tests of createrepo_c to also test this new feature in my PR.

But generally AC:
- createrepo_c can parse updateinfo with <reboot_suggested> inside the <update> element and expose the value in python
- its possible to set reboot_suggested on UpdateRecord from python and then dump this updateinfo with the value present
- the default value of reboot_suggested in UpdateRecord when no value is provided is 0.

Comment 11 errata-xmlrpc 2020-04-28 15:39:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1620


Note You need to log in before you can comment on or make changes to this bug.