Bug 1772624 - dehypht-x-2018-03-31.tex not found, only dehypht-x-2019-04-04.tex is provided.
Summary: dehypht-x-2018-03-31.tex not found, only dehypht-x-2019-04-04.tex is provided.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-14 18:56 UTC by Qiyu Yan
Modified: 2019-11-24 02:24 UTC (History)
3 users (show)

Fixed In Version: texlive-2019-6.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-24 02:24:30 UTC
Type: Bug


Attachments (Terms of Use)
Output for fmtutil-user --all without workground (387.52 KB, text/plain)
2019-11-15 16:17 UTC, Qiyu Yan
no flags Details
Output for fmtutil-user --all with workground (461.21 KB, text/plain)
2019-11-15 16:18 UTC, Qiyu Yan
no flags Details

Description Qiyu Yan 2019-11-14 18:56:58 UTC
Description of problem:
files in "/usr/share/texlive/texmf-dist/tex/generic/dehyph-exptl" was updated to 2019-04-04 but some texlive components is stil looking for 2018-03-31. Causing fmtutil-sys become unusable.

Version-Release number of selected component (if applicable):
texlive-dehyph-exptl-svn50772-5.fc32.noarch
texlive-2019-5.fc32.noarch

How reproducible:
Always

Steps to Reproduce:
1.Install texlive-scheme-medium
2.Compile any tex source file by xelatex/pdflatex 
3.Compile failed due to unable to find dehypht-x-2018-03-31.tex

Actual results:
Tex program says it was unable to find dehypht-x-2018-03-31.tex and exits.

Expected results:
Tex should look for dehypht-x-2019-04-04.tex .

Additional info:
By puting symbol links in /usr/share/texlive/texmf-dist/tex/generic/dehyph-exptl from *2019-04-04.* to *2018-03-31.* can be a workaround.

Comment 1 Tom "spot" Callaway 2019-11-15 14:52:43 UTC
Hmmm. I wonder if this isn't something in your ~/.texlive20* cache that's causing issues.

Can you provide a very specific source file and execution reproducer case for me to test?

Comment 2 Qiyu Yan 2019-11-15 16:17:43 UTC
Created attachment 1636573 [details]
Output for fmtutil-user --all without workground

Comment 3 Qiyu Yan 2019-11-15 16:18:42 UTC
Created attachment 1636574 [details]
Output for fmtutil-user --all with workground

Comment 4 Qiyu Yan 2019-11-15 16:19:57 UTC
To avoid affects from ~/.texlive20* cache, I did those things
1. rm -rf ~/texlive2019 and sudo rm -rf /usr/share/texlive/texmf-dist/tex/generic/dehyph-exptl/*-2018* 
2. texhash
3. fmtutil-user --all>fmt.log : Here fmtutil reports some error.
4. rm -rf ~/texlive2019 and recreate those symlink.
5. texhash
6. fmtutil-user --all>workaround.log : Here no error is reported. 

Two output has been put above. And reported error in step 3 is :

fmtutil [ERROR]: running `luatex -ini   -jobname=luatex -progname=luatex luatex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdftex -progname=pdftex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `luajittex -ini   -jobname=luajittex -progname=luajittex luatex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `xetex -ini   -jobname=xetex -progname=xetex -etex xetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfetex -progname=pdfetex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=etex -progname=etex -translate-file=cp227.tcx *etex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `luatex -ini   -jobname=dviluatex -progname=dviluatex dviluatex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict

Comment 5 Tom "spot" Callaway 2019-11-15 16:45:25 UTC
I see the bug now, this one's my fault.

Comment 6 Fedora Update System 2019-11-18 17:27:47 UTC
FEDORA-2019-88ffe47587 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-88ffe47587

Comment 7 Fedora Update System 2019-11-19 03:15:44 UTC
texlive-2019-6.fc31, texlive-base-20190410-6.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-88ffe47587

Comment 8 Fedora Update System 2019-11-24 02:24:30 UTC
texlive-2019-6.fc31, texlive-base-20190410-6.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.