Bug 1772687 - Upgrade from 4.2.2 to 4.2.4 causes Console CSS to break/not render until cache is cleared
Summary: Upgrade from 4.2.2 to 4.2.4 causes Console CSS to break/not render until cach...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.z
Hardware: x86_64
OS: Mac OS
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1774508 1780254
TreeView+ depends on / blocked
 
Reported: 2019-11-14 21:14 UTC by Rob Szumski
Modified: 2020-01-23 11:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, in some cases after upgrading your cluster, the web console could use cached CSS stylesheets, which would cause some visual issues on load. The problem has been fixed, and the console will correctly use the updated stylesheets after an upgrade.
Clone Of:
: 1774508 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Broken CSS in Console (184.66 KB, image/png)
2019-11-14 21:14 UTC, Rob Szumski
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3404 0 'None' 'closed' 'Bug 1772687: webpack: include contenthash in CSS filenames' 2019-12-05 15:01:37 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:13:06 UTC

Description Rob Szumski 2019-11-14 21:14:11 UTC
Created attachment 1636277 [details]
Broken CSS in Console

Description of problem:
Upgrading from 4.2.2 to 4.2.4 using Safari caused the Console to not render CSS and be completely unusable until the cache was cleared and the browser was restarted.

Version-Release number of selected component (if applicable):
OCP 4.2.2

How reproducible:
Upgrade from 4.2.2 to 4.2.4 using Safari 13.0.3 on MacOS 10.14.6.

Steps to Reproduce:
1. Click upgrade in Cluster Settings

Actual results:
See screenshot

Comment 2 Yadan Pei 2019-11-15 03:05:35 UTC
Hi Sam,

The issue described in this bug is CSS loading error after upgrade. What's the root cause of it? 

It was found in 4.2.2 -> 4.2.4 upgrade but fixed in 4.3, then how can I verify it? 

I guess if I can verify the fix during a 4.3.x -> 4.3.x upgrade or 4.2.x -> 4.3.x upgrade

Comment 3 Samuel Padgett 2019-11-19 13:33:09 UTC
I would open the networking tab in the browser developer tools prior to loading console. Make sure "Disable Cache" is *not* checked. Load the console after the upgrade. Make sure none of the CSS requests come from cache. You can use the CSS filter for network request. The responses should all have status 200 instead of 304.

Comment 4 shahan 2019-11-20 08:17:04 UTC
Check the dev console ignoring the resource cache when loading pages,all network requests status are 200.
Verified this bug.
4.2.7->4.3.0-0.nightly-2019-11-19-122017
Safari Version 11.0.3

Comment 6 errata-xmlrpc 2020-01-23 11:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.