Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1772688

Summary: When a SHE-eligible host power fails and reboots, it connects to the SHE storage domain but no other SDs; it works fine after another orderly reboot.
Product: Red Hat Enterprise Virtualization Manager Reporter: Greg Scott <gscott>
Component: ovirt-engineAssignee: Benny Zlotnik <bzlotnik>
Status: CLOSED WONTFIX QA Contact: Avihai <aefrat>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.2.6CC: ahadas, bzlotnik, gveitmic, lsurette, michal.skrivanek, mkalinin, pelauter, shipatil
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-06-06 14:53:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1651840    
Bug Blocks:    

Description Greg Scott 2019-11-14 21:23:21 UTC
Description of problem:
When a SHE-eligible host power fails and reboots, it connects to the SHE storage domain, but fails to connect to other storage domains; it works fine after another orderly reboot.

Version-Release number of selected component (if applicable):
4.2.6

How reproducible:
At will

Steps to Reproduce:
1. Kill the power to one SHE-eligible RHV host. Power it back up and it reboots.
2. The host connects to the SHE storage domain, but fails trying to connect to any other storage domain.
3. Put the host through an orderly shutdown and reboot sequence. Now it connects to all storage domains just fine.

Actual results:
The SHE-eligible host fails to to connect to any storage domain other than the SHE storage domain. Clicking "Confirm host has been rebooted" has no effect. Only a subsequent orderly shutdown and reboot sequence seems to clear the problem.

Expected results:
The SHE-eligible host should connect to all storage domains when it reboots.

Additional info:
This installation uses full RHEL hosts with VDSM, not RHV-H.

Comment 1 Germano Veit Michel 2019-11-18 00:59:42 UTC
Upstream of what appears to be the same thing: BZ1651840

Comment 2 Sandro Bonazzola 2019-11-18 08:46:58 UTC
Connection to the remaining storage domains is not handled by ovirt-hosted-engine-ha. It's done by regular ovirt-engine/vdsm interaction.
I think Germano is right, the problem is the one described in BZ #1651840.
Keeping this open being the other one upstream.

Comment 7 Marina Kalinin 2021-05-24 19:45:36 UTC
This bug impacts SHE deployments and causes production down environment requiring human intervention to recover.
We have more than 1  customer hit this.
I recommend fixing this bug.

Comment 8 Marina Kalinin 2021-05-24 19:46:41 UTC
*** Bug 1651840 has been marked as a duplicate of this bug. ***