Bug 177271 - cpio can't backup files on ext3 unless fs created with largefile support
cpio can't backup files on ext3 unless fs created with largefile support
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cpio (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 12:28 EST by sean fulton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 05:04:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean fulton 2006-01-08 12:28:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Backing up files larger than 2 Gbytes in size with cpio results in the error: "Value too large for defined data type" and the files are skipped.

I thought it was a problem with CPIO, and downloaded and re-compiled many versions, all with the same result. It turns out that cpio will archive files larger than 2 Gbytes if they are an ext3 filesystem created with -T largefile. But on filesystems created with the default ext3 fs creation options, it fails.

This is an issue because we have a filesystem on web content which is mainly small files, yet there are one or two large files that need to be backed up. Our current cpio-based backup scripts simply skip the files.

Please note that other utilities, inclusing zcat and dd work on large files which cpio fails to copy. For example, I can do zcat largefile.cpio | cpio -itv with no problem.



Version-Release number of selected component (if applicable):
cpio-2.5-3.2.legacy.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Create a file 3 GB in size (largefile.tar)
2. ls *.tar | cpio -ov -O./backup.cpio
3. You get the error.
4. Copy file to a machine with ext3 -T largefile used to create the filesystems
5. ls *.tar | cpio -ov -O./backup.cpio
6. It works!
  

Actual Results:  Value too large for defined data type

Expected Results:  File should be backed up.

Additional info:
Comment 1 Jesse Keating 2006-01-08 12:36:12 EST
This sounds like a non-legacy specific issue.  This is an upstream cpio issue,
and should be filed upstream with them.
Comment 2 Jesse Keating 2006-01-08 12:37:53 EST
Does this still happen in Fedora Core Devel (or even FC4 for that matter)?
Comment 3 sean fulton 2006-01-08 13:00:24 EST
The latest version I tried to was 2.6-2, which I think came from the pre-release
FC4. I downloaded and compiled cpio-2.6-2.src.rpm on the target system with no luck.

Comment 4 Peter Vrabec 2006-01-09 05:04:39 EST
Try cpio-2.6-9.FC4 or cpio-2.6-10(devel), file limit size has been enlarged to
4GB there. Because of cpio header it is not possible to get over 4GB limit.It's
up to upstream to change it.

Note You need to log in before you can comment on or make changes to this bug.