Bug 177273 - Error when Creating New Form
Error when Creating New Form
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gambas (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 13:27 EST by Tejas Dinkar
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 10:53:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tejas Dinkar 2006-01-08 13:27:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I attempt to create a new form in gambas, it gives me the error:

Cannot Open File
Component Missing: FForm.CreateControl.833

and cannot show the form.

Version-Release number of selected component (if applicable):
gambas-1.0.11-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Install gambas via yum
2. Create a Project
3. Attempt to Create a New Form

Actual Results:  Recieved the Error Message:

Cannot Open File
Component Missing: FForm.CreateControl.833

Expected Results:  New Form Created

Additional info:
Comment 1 Tom "spot" Callaway 2006-01-08 13:48:40 EST
Hmm, while I can't reproduce this one, I think I know why you're having it.

Yum doesn't seem to be obsoleting the old gambas packages properly (I redid the
naming scheme on the packages to make upstream happy), so you have bits of the
old 1.0.11 installed along side the new 1.0.13.

Try this:

rpm -qa |grep gambas|xargs rpm -e

This should flush out the old gambas (and the new gambas).

Now, run:

yum install gambas-gb-compress gambas-gb-db gambas-gb-debug gambas-gb-eval
gambas-gb-net gambas-gb-net-curl gambas-gb-qt gambas-gb-qt-editor
gambas-gb-qt-ext gambas-gb-qt-kde gambas-gb-qt-kde-html gambas-gb-sdl
gambas-gb-vb gambas-gb-xml-libxml gambas-gb-xml-libxml-rpc
gambas-gb-xml-libxml-xslt gambas-ide gambas-runtime

(all one line)

Now, you should have all of 1.0.13 installed, and none of 1.0.11. Try running
gambas now. I was able to create a new form with no errors here.
Comment 2 Tejas Dinkar 2006-01-08 20:52:47 EST
hmm, very strange...

Gambas is working now, thank you.

However, the following points may be noted:

1) The first time I had only `yum installed gambas`... and none of the other
rpms. It was a 1.x MB download, and Appeared to work

2) Thus I only had 1 gambas component - Gambas itself (v 1.0.11)

3) After removing Gambas as you asked and installing all those other components,
I was faced with a 36 MB download (including gcc).

Hense, I feel that perhaps Gambas should have a dependency on some of those
other components.

Otherwise, this bug is RESOLVED

Note You need to log in before you can comment on or make changes to this bug.