Bug 177278 - anaconda --livecd unknown option
anaconda --livecd unknown option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kadischi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Darko Ilic
Darko Ilic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 14:01 EST by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-08 14:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2006-01-08 14:01:14 EST
Description of problem:

Anaconda fails to run due to unknown "--livecd" option

Version-Release number of selected component (if applicable):

kadischi 0.1
anaconda 10.90.20

How reproducible:

100%

Steps to Reproduce:

# kadischi http://shuttle/fc5/i386 /tmp/andy.iso

Actual results:

Starting kadischi...
Parsing command line arguments
Checking UID
Using buildstamp file /etc/kadischi/buildstamp.
Product path set to Fedora.
Now we are going to try to validate your repository (for now, only http, ftp and
local repositories can be checked)
URL http://shuttle/fc5/i386 contacted. OK
URL http://shuttle/fc5/i386/Fedora contacted. OK
URL http://shuttle/fc5/i386/Fedora/base contacted. OK
URL http://shuttle/fc5/i386/Fedora/RPMS contacted. OK
Repository seems to be OK.
Checking required packages
Looking for config file
Loadnig config file options

  ***  running anaconda  ***

Error bad argument --livecd: unknown option

:
  ***  Fatal error: anaconda returned non zero (65280) exit code. Aborting
execution.

Cleaning up temporary files...
Done.
Comment 1 Andy Burns 2006-01-08 14:34:02 EST
Ok, so I didn't notice I needed to do

patch -b /usr/sbin/anaconda /usr/local/share/kadischi/patches/anaconda.patch 
patch -b /usr/lib/anaconda/flags.py /usr/local/share/kadischi/patches/flags.py.patch

one of the hunks woulnd't apply, purely cosmetic change to anaconda so added it
manually, I do now get anaconda starting ...

Note You need to log in before you can comment on or make changes to this bug.