Bug 177280 - A server with a printer must have gphoto2
Summary: A server with a printer must have gphoto2
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-08 20:47 UTC by Pete Zaitcev
Modified: 2014-03-17 02:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 18:34:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pete Zaitcev 2006-01-08 20:47:45 UTC
I cannot get rid of gphoto2, apparently, because I have an HP printer.

[root@mallorn zaitcev]# rpm -e gphoto2
error: Failed dependencies:
        libgphoto2.so.2 is needed by (installed) sane-backends-1.0.17-0.fc4.1.i386
        libgphoto2_port.so.0 is needed by (installed)
sane-backends-1.0.17-0.fc4.1.i386
[root@mallorn zaitcev]# rpm -e sane-backends
error: Failed dependencies:
        sane-backends is needed by (installed) libsane-hpaio-0.9.7-4.2.i386
[root@mallorn zaitcev]# rpm -e libsane-hpaio
error: Failed dependencies:
        libhpip.so.0 is needed by (installed) hpijs-0.9.7-4.2.i386
[root@mallorn zaitcev]#

I don't have a good suggestion how to resolve this. But it looks weird,
doesn't it?

This came about now because I upgraded an FC3 box to FC4 and noticed
that gphoto2 is being downloaded. Not a super high priority. Disk space
is cheap. I mostly care because it's a VIA box and yum gets bogged down,
so I want fewer packages on a server.

Comment 1 Bill Nottingham 2006-01-09 18:34:08 UTC
It's odd, but I don't think it's worth the effort to try and split the backends
up by type, because then you have to try and figure out how to sanely get them
onto the system based on what devices are plugged in at the moment.


Note You need to log in before you can comment on or make changes to this bug.