Bug 1772839 - ingress and routes should be present in related objects for authentication operator [NEEDINFO]
Summary: ingress and routes should be present in related objects for authentication op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Michal Fojtik
QA Contact: scheng
URL:
Whiteboard:
Depends On: 1782124
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 09:51 UTC by Michal Fojtik
Modified: 2019-12-20 00:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1782124 (view as bug list)
Environment:
Last Closed: 2019-12-20 00:46:48 UTC
Target Upstream Version:
scheng: needinfo? (eparis)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 217 'None' closed Bug 1772839: operator: add ingress and routes to related objects 2020-04-29 00:22:21 UTC
Red Hat Product Errata RHBA-2019:4181 None None None 2019-12-20 00:46:57 UTC

Description Michal Fojtik 2019-11-15 09:51:06 UTC
Description of problem:

The ingress namespace and routes should be present in authentication operator so when auth operator is degraded, must-gather will fetch those for inspection.

Additionally, the insights operator should collect events from ingress namespace so in case telemetry is reporting degraded authentication operator, we can inspect events in ingress namespace and see if the ingress working properly.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 10 errata-xmlrpc 2019-12-20 00:46:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4181


Note You need to log in before you can comment on or make changes to this bug.