Bug 1772849 - 'Number of pods' host query is not valid range query for query_range prometheus endpoint
Summary: 'Number of pods' host query is not valid range query for query_range promethe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 10:16 UTC by Jiri Tomasek
Modified: 2020-01-23 11:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3416 'None' 'open' 'Bug 1772849: Fix NUMBER_OF_PODS host query' 2019-11-15 10:18:41 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:06 UTC

Description Jiri Tomasek 2019-11-15 10:16:40 UTC
Description of problem:
'Number of pods' host query is not valid range query for query_range prometheus endpoint.
Error: invalid expression type "range vector" for range query, must be Scalar or instant Vector

Steps to Reproduce:
1. Navigate to bare metal host detail page, Dashboard tab
2. Utilization card - Number of Pods graph shows 'No datapoints found'
3.

Actual results:
Utilization card - Number of Pods graph shows 'No datapoints found'


Expected results:
Utilization card - Number of Pods graph shows correct pod count graph

Comment 4 errata-xmlrpc 2020-01-23 11:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.