Bug 1772874 - Bare metal host popovers does not display anything in the Top Consumers
Summary: Bare metal host popovers does not display anything in the Top Consumers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 12:24 UTC by Constantin Vultur
Modified: 2020-01-23 11:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3419 'None' closed Bug 1772874: Convert host queries to use node name instead of InternalIP 2020-04-27 10:17:15 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:13:26 UTC

Description Constantin Vultur 2019-11-15 12:24:31 UTC
Description of problem:
In the Utilization card of the Bare Metal Host Dashboard, while checking the Popovers for the 'CPU Usage' / 'Memory Usage' / 'Filesystem usage', the Top consumers list is empty. 
Also while clicking on 'View More', in the new page that opens, the query returns "No datapoints found". 
In my case the query was: 

topk(25, sort_desc(sum(container_memory_working_set_bytes{instance=~"172.22.0.98:.*",container="",pod!=""}) BY (pod, namespace)))

Version-Release number of selected component (if applicable):
4.3.0-0.ci-2019-11-15-015333

How reproducible:


Steps to Reproduce:
1. navigate to Compute > Bare Metal Hosts 
2. select one bare metal host and check the Dashboard
3. on the Utilization card, click on the Usage for any of the 'CPU Usage' / 'Memory Usage' / 'Filesystem usage' 
4. click in 'View More'

Actual results:
- list of Top Consumers is empty
- in the metrics window, the query returns 'No datapoints found'

Expected results:
- list of Top consumers and the details in the Metrics windows

Additional info:

Comment 4 errata-xmlrpc 2020-01-23 11:13:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.