Bug 177288 - bash fails to execute autoconf-generated script
Summary: bash fails to execute autoconf-generated script
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-09 02:35 UTC by Tom Lane
Modified: 2013-07-03 03:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 16:26:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Lane 2006-01-09 02:35:51 UTC
Description of problem:
Latest bash fails to execute configure script

Version-Release number of selected component (if applicable):
bash-3.1-2

How reproducible:
100%

Steps to Reproduce:
1.  Try to build postgresql in beehive
2.  Notice that configure script for the "pgtcl" component fails

Actual results:
...
checking if 64bit support is enabled... no
checking if 64bit Sparc VIS support is requested... no
checking system version (for dynamic loading)... ./configure: line 5698: syntax error near unexpected 
token `('
./configure: line 5698: `    case `(ac_space=' '; set | grep ac_space) 2>&1` in'
[root@ls20-bc1-13 Pgtcl]# 

The "checking system version" message is at line 3546; I'm not sure how control suddenly jumps two 
thousand lines further down, but running the script under sh -x confirms that's what it's doing.

Expected results:
successful execution of script

Additional info:
The postgresql specfile forcibly re-autoconfs this sub-package, so the failing script has just been built 
by autoconf.  I first thought that autoconf might be broken, but this same package has been built 
successfully since the last autoconf update, so the blame seems to rest with bash.

I've assigned this "high" priority because it's blocking me from updating postgresql, which I really 
wanted to do before fc5test2 freeze :-(

Comment 1 Tom Lane 2006-01-09 02:48:34 UTC
The script seems a bit large to attach to this bz entry, but I've left a copy as ~tgl/configure on porkchop.

Comment 2 Tim Waugh 2006-01-09 16:26:43 UTC
Buggy script at line 3561:

                system=MP-RAS-`awk '{print }' /etc/.relid'`

should read

                system=MP-RAS-`awk '{print }' /etc/.relid`

i.e. take out the third single-quote.

Comment 3 Tom Lane 2006-01-09 17:08:55 UTC
Argh, sorry to bother you with such a stupid thing.  It's weird though that this
script did not fail before.  Have bash's quoting rules changed recently?

Comment 4 Tim Waugh 2006-01-09 17:17:11 UTC
Indeed, bash-3.0 does not fail on that code.  It must just be some small parser
change.  I think it's just good luck that it didn't fail before.


Note You need to log in before you can comment on or make changes to this bug.