Bug 1772893 - Polymake needs to be updated for perl 5.30.1-448
Summary: Polymake needs to be updated for perl 5.30.1-448
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: polymake
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1773998 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 13:15 UTC by Eugene Mah
Modified: 2020-03-18 22:37 UTC (History)
4 users (show)

Fixed In Version: polymake-3.5-5.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-28 01:10:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Eugene Mah 2019-11-15 13:15:49 UTC
Description of problem:
polymake-3.5-4.fc31.x86_64 doesn't like the perl-5.30.1-448.fc31 that is currently in updates-testing.

Version-Release number of selected component (if applicable):


How reproducible:
dnf upgrade

Steps to Reproduce:
1. dnf upgrade
2.
3.

Actual results:
 Problem 1: package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - cannot install both perl-interpreter-4:5.30.1-448.fc31.x86_64 and perl-interpreter-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-interpreter-4:5.30.0-446.fc31.x86_64 and perl-interpreter-4:5.30.1-448.fc31.x86_64
  - cannot install the best update candidate for package polymake-singular-3.5-4.fc31.x86_64
  - cannot install the best update candidate for package perl-interpreter-4:5.30.0-446.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
 Problem 2: package python3-JuPyMake-0.8-8.fc31.x86_64 requires libpolymake.so.3.5()(64bit), but none of the providers can be installed
  - package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - cannot install both perl-interpreter-4:5.30.1-448.fc31.x86_64 and perl-interpreter-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-interpreter-4:5.30.0-446.fc31.x86_64 and perl-interpreter-4:5.30.1-448.fc31.x86_64
  - package perl-4:5.30.1-448.fc31.x86_64 requires perl-interpreter(x86-64) = 4:5.30.1-448.fc31, but none of the providers can be installed
  - cannot install the best update candidate for package python3-JuPyMake-0.8-8.fc31.x86_64
  - cannot install the best update candidate for package perl-4:5.30.0-446.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
 Problem 3: package polymake-3.5-4.fc31.x86_64 requires polymake-singular(x86-64) = 3.5-4.fc31, but none of the providers can be installed
  - package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - package perl-interpreter-4:5.30.0-446.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.0-446.fc31, but none of the providers can be installed
  - cannot install both perl-libs-4:5.30.1-448.fc31.x86_64 and perl-libs-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-libs-4:5.30.0-446.fc31.x86_64 and perl-libs-4:5.30.1-448.fc31.x86_64
  - cannot install the best update candidate for package polymake-3.5-4.fc31.x86_64
  - cannot install the best update candidate for package perl-libs-4:5.30.0-446.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
 Problem 4: problem with installed package polymake-singular-3.5-4.fc31.x86_64
  - package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - package perl-interpreter-4:5.30.0-446.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.0-446.fc31, but none of the providers can be installed
  - cannot install both perl-libs-4:5.30.1-448.fc31.x86_64 and perl-libs-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-libs-4:5.30.0-446.fc31.x86_64 and perl-libs-4:5.30.1-448.fc31.x86_64
  - package perl-Errno-1.30-448.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.1-448.fc31, but none of the providers can be installed
  - cannot install the best update candidate for package perl-Errno-1.30-446.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
 Problem 5: problem with installed package python3-JuPyMake-0.8-8.fc31.x86_64
  - package python3-JuPyMake-0.8-8.fc31.x86_64 requires libpolymake.so.3.5()(64bit), but none of the providers can be installed
  - package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - package perl-interpreter-4:5.30.0-446.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.0-446.fc31, but none of the providers can be installed
  - cannot install both perl-libs-4:5.30.1-448.fc31.x86_64 and perl-libs-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-libs-4:5.30.0-446.fc31.x86_64 and perl-libs-4:5.30.1-448.fc31.x86_64
  - package perl-devel-4:5.30.1-448.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.1-448.fc31, but none of the providers can be installed
  - cannot install the best update candidate for package perl-devel-4:5.30.0-446.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
 Problem 6: package perl-4:5.30.0-446.fc31.x86_64 requires perl-libs(x86-64) = 4:5.30.0-446.fc31, but none of the providers can be installed
  - problem with installed package perl-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-libs-4:5.30.1-448.fc31.x86_64 and perl-libs-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-libs-4:5.30.0-446.fc31.x86_64 and perl-libs-4:5.30.1-448.fc31.x86_64
  - perl-libs-4:5.30.1-448.fc31.i686 has inferior architecture
  - package perl-utils-5.30.1-448.fc31.noarch requires perl-libs = 4:5.30.1-448.fc31, but none of the providers can be installed
  - cannot install the best update candidate for package perl-utils-5.30.0-446.fc31.noarch
  - package perl-4:5.30.1-448.fc31.x86_64 requires perl-interpreter(x86-64) = 4:5.30.1-448.fc31, but none of the providers can be installed
  - package polymake-doc-3.5-4.fc31.x86_64 requires polymake(x86-64) = 3.5-4.fc31, but none of the providers can be installed
  - package polymake-3.5-4.fc31.x86_64 requires polymake-singular(x86-64) = 3.5-4.fc31, but none of the providers can be installed
  - package polymake-singular-3.5-4.fc31.x86_64 requires perl-interpreter = 4:5.30.0, but none of the providers can be installed
  - cannot install both perl-interpreter-4:5.30.1-448.fc31.x86_64 and perl-interpreter-4:5.30.0-446.fc31.x86_64
  - cannot install both perl-interpreter-4:5.30.0-446.fc31.x86_64 and perl-interpreter-4:5.30.1-448.fc31.x86_64
  - cannot install the best update candidate for package polymake-doc-3.5-4.fc31.x86_64
  - package perl-interpreter-4:5.30.0-443.module_f31+5982+3dad29a3.x86_64 is excluded
  - package perl-interpreter-4:5.30.0-446.module_f31+6438+366a2e33.x86_64 is excluded
==============================================================================================================================================================
 Package                                 Architecture                  Version                                   Repository                              Size
==============================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 perl-interpreter                        x86_64                        4:5.30.1-448.fc31                         updates-testing                        6.1 M
 perl-libs                               x86_64                        4:5.30.1-448.fc31                         updates-testing                        1.7 M
Skipping packages with broken dependencies:
 perl                                    x86_64                        4:5.30.1-448.fc31                         updates-testing                         22 k
 perl-Errno                              x86_64                        1.30-448.fc31                             updates-testing                         26 k
 perl-devel                              x86_64                        4:5.30.1-448.fc31                         updates-testing                        713 k
 perl-utils                              noarch                        5.30.1-448.fc31                           updates-testing                         78 k

Transaction Summary
==============================================================================================================================================================
Skip  6 Packages


Expected results:
perl-5.30.1-448.fc31 should be updated

Additional info:

Comment 1 Fedora Update System 2019-11-19 04:30:01 UTC
FEDORA-2019-bf01e6f295 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf01e6f295

Comment 2 Eugene Mah 2019-11-19 11:38:26 UTC
Everything seems to be working fine now.  Gave a thumbs up on the update

Comment 3 James Paul Turner 2019-11-19 14:11:13 UTC
*** Bug 1773998 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-11-20 01:27:39 UTC
polymake-3.5-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf01e6f295

Comment 5 Fedora Update System 2019-11-28 01:10:21 UTC
polymake-3.5-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 william.garber 2020-03-18 22:37:09 UTC
this bug still exists.


Note You need to log in before you can comment on or make changes to this bug.